[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] max loop

  • To: Mitch <mitchkelly@xxxxxxxxxxxxxx>
  • From: Nico Kadel-Garcia <nkadel@xxxxxxxxx>
  • Date: Wed, 07 Nov 2007 11:04:26 +0000
  • Cc: Geoff Kirk <geoff.k@xxxxxxxxxxxxxxxxxxx>, xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Wed, 07 Nov 2007 03:03:39 -0800
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:user-agent:mime-version:to:cc:subject:references:in-reply-to:content-type:content-transfer-encoding; b=MjuG+VJXm17/UzfwSWY98NIJlz97YVKwwTuAoH9H02xM5GBMOpKiwhA55LFSEnF8QOAJeTRxDrwerOAYlY/HH6sZRT/twjmMYflYdyKmD8VrTS6C+3ncs6B2SQnNvMxH0mpL3r7/1LMQKjttJPtzBpqf+7WlwDO+otzcWyG1PHw=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Mitch wrote:
i had exactly the same problem

This fixed it:
edit /etc/xen/network-bridge
Find the line that says:
${vifnum:-$(ip route list | awk '/^default / { print $NF }' | sed 's/^[^0-9]*//')}
Comment it out
Put there instead:
Reboot PC

Loaded up 12Xens so far with no issues.

My original problem was related to the max_loop and it wouldnt bring up peth0 veth0 xenbr0, The fix above fixed it..
if you type: ip route list | awk '/^default /'
It should say something like this:
default via xxx.xxx.xxx.xxx dev eth0  metric 100
The problem is it tried to make veth100...

let me know how you go..

Then shouldn't it be changed to something like this?

${vifnum:-$(ip route list | sed 's/ metric .*//g' | awk '/^default / { print $NF }' | sed 's/^[^0-9]*//')}

shouldn't it?

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.