[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Dom0 crash on hvm creation


I'm having some trouble trying to run Centos4 hvm domU domains on a Centos 
5 server running kernel-2.6.18-8.1.15.el5.centos.plusxen, using xen 
3.0.3-25.0.4.el5 on x86_64 architecture. On three out of four of the 
servers I've tried, I will get a total system (dom0) crash when trying to 
start a fully virtualized domU. I will run `xm create xen_test`, it will 
start, then return to the command line, but invariably within five to ten 
seconds the entire system will freeze. I get no error messages to any of 
the logs, or anything output to the console. Absolutely nothing responds. I 
can't find any record of the error after power cycling the machine.

The interesting thing is that on one server of the same type out of the 
four I've tried, it works absolutely fine every time. I've tried moving the 
hvm image and config to the other servers but those fail as well. There 
might be some differences in the hardware components used but the servers 
have the same board and same CPUs, with the same version of Centos and Xen.

I did read that some people were having problems with hvm crashing the dom0 
a while back on the list when using AMD 64 cpus. I don't know if that would 
apply to this version of xen or if it might be somehow related, but I 
thought it was a good chance. Porting xen 3.1 to the kernel-xen RPM is an 
option, but one I'd really like to avoid if possible.


Brendan Wood

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.