[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Installing openSuSE 10.3 as PV-guest on a LVM-drive of a openSuSE 10.3 host

  • To: xen-users <xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: Thorolf Godawa <nospam@xxxxxxxxx>
  • Date: Sun, 18 Nov 2007 21:13:23 +0100
  • Delivery-date: Sun, 18 Nov 2007 12:14:04 -0800
  • List-id: Xen user discussion <xen-users.lists.xensource.com>


how can I install a openSuSE 10.3 PV-guest on a LVM-drive of a openSuSE
10.3 host with Xen 3.10?

On 10.2 with Xen 3.0.3 the openSuSE-YaST-module for managing VMs could
install the system also on block-devices, unfortunately this is not
possible anymore with OSS 10.3 :-(

What I have tried:

- I created two LVM-partitions, one for "/" one for swap.

- Installing an OSS 10.2 PV-guest on the 10.2-host using block-devices
works without any problems, but the upgrade of the guest to OSS 10.3
failed (the system hangs during boot).

- It was NOT possible to install OSS 10.3 as PV-guest on LVM-partitions
on the 10.2-host using the YaST-module, the installation stops and tells
me that it can't extract kernel/initrd from the installation media (I
tried DVD-, CD- and network-install).

- On OSS 10.3 as host I can install 10.3 as PV-guest using a file as
image-container, everything works as expected.

- I tried to move this working image to the LVM-drives:
  - I create one primary partition on each LVM-drive, formated one
    with ext3 and the other with swap.
  - I mounted the the OSS 10.3 image-file as loop with offset that
    it matches the internal partition table.
  - I mounted the new LVM-drive that should be used, also with
    loop and offset.
  - I can access both mounted filesystems correctly, so I copied
    everything from the image-file to the LVM-drive.
  - I checked the /etc/fstab in the new copy:
    /dev/xvda1    /            ext3     acl,user_xattr        1 1
    /dev/xvdb2    swap         swap     defaults              0 0
  - I created a new xen-config:
    #extra=" "
    extra=" TERM=xterm"
    disk=[ 'phy:/dev/vg01/pv-sys,xvda,w',
                                 'phy:/dev/vg01/pv-swap,xvdb,w' ]
    vif=[ 'mac=00:12:34:56:78:9a', ]
  - I start this system , but mostly nothing happens, no error, no boot:
    # xm create OSS103.lvm
      -> Using config file "./OSS103.lvm".
    # xm list
      -> Name               ID   Mem VCPUs      State   Time(s)
         OSS103.lvm          2   384     0     -bp---      0.0
    # xm unpause OSS103.lvm
    # xm list
      -> Name               ID   Mem VCPUs      State   Time(s)
         OSS103.lvm          2   384     0     -b----      0.0
  - There is are only entries in the xend.log:
    57:27 3636] DEBUG (XendDomainInfo:78) XendDomainInfo.create(['vm',
['name', 'OSS103.lvm'], ['memory', 384], ['on_poweroff', 'destroy'],
['on_reboot', 'restart'], ['on_crash', 'destroy'], ['vcpus', 1],
['on_xend_start', 'ignore'], ['on_xend_stop', 'ignore'], ['uuid',
'fa0be596-08aa-361b-a10b-51056bf71c45'], ['bootloader',
'/usr/lib/xen/boot/domUloader.py'], ['bootloader_args', '-q'], ['image',
['linux', ['args', ' TERM=xterm']]], ['device', ['vbd', ['uname',
'phy:/dev/vg01/pv-sys'], ['dev', 'xvda'], ['mode', 'w']]], ['device',
['vbd', ['uname', 'phy:/dev/vg01/pv-swap'], ['dev', 'xvdb'], ['mode',
'w']]], ['device', ['vif', ['mac', '00:16:3e:5d:16:c2']]]])
    57:27 3636] DEBUG (XendDomainInfo:1512) XendDomainInfo.constructDomain
    57:27 3636] DEBUG (balloon:132) Balloon: 94628 KiB free; need 2048;
    57:27 3636] DEBUG (XendDomain:435) Adding Domain: 2
    57:27 3636] DEBUG (XendDomainInfo:1566) XendDomainInfo.initDomain: 2 256
    57:27 4423] DEBUG (XendBootloader:101) Launching bootloader as
['/usr/lib/xen/boot/domUloader.py', '--args= TERM=xterm', '--o
utput=/var/run/xend/boot/xenbl.20430', '-q', '/dev/vg01/domino-sys'].
    59:49 3636] INFO (XendDomain:1141) Domain OSS103.lvm (2) unpaused.
    05:57 3636] DEBUG (XendDomainInfo:1758) XendDomainInfo.destroy: domid=2
    05:57 3636] DEBUG (XendDomainInfo:1775) XendDomainInfo.destroyDomain(2)

- Finally I made a directory-install of OSS 10.3 into the mounted
LVM-drive, adjusted the /etc/fstab and passwd/shadow/group but the
result was exactly the same :-(

Any ideas how I can solve this problem?

Thanks a lot,

Chau y hasta luego,


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.