[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] CentOs 5.1 and dnsmasq interference

Sadique Puthen wrote:
Steven wrote:
Hi all,

From the release notes of CentOS 5.1 I read:

"if you use the Virtualization suite (Xen etc.) then the package libvirt will get installed. Since CentOS 5.1 this package has a dependency for dnsmasq, which is a lightweight DNS and DHCP server. If you have any other DNS or DHCP daemons running on the same system you should check that dnsmasq does not interfere with those."

This breaks networking for all my domU but their is no released workaround. My work around was to revert back to previous version.
Has anyone figure out how to get rid of dnsmasq without breaking Xen?

You just disable dnsmasq from getting auto started by libvirtd. See /etc/libvirt/qemu/networks/autostart for more details.


I removed the simblink to ../default.xml and restarted xen and that solved my issus, now it works as it was before.

Thanks for your support.



Steven Dugway

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.