[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Problem of Xen in Combination with NFS

Juche List,

here is what I found out today. This Error was reproducable on two different machines, and I cannot think of the reason for the Problem, maybe I should post it on some NFS list, thats what I'll try next, but first I try here.

I use NFS to communicate data between dom0 and domU. I export some folder in dom0 and mount that export as /home in domU

When I write data from domU into /home the system looses its Network Connection (writing data from domU --> dom0). Strangely that only happens with files bigger then 200kB. There is no problem to write e.g. 50 kB into /home.

I can still login on xm console domU but after some moments the system can only be shut down using xm destroy domU.

If I try to recreate domU i get the error:

Using config file "/home/vserver/springfield/start-springfield".
Error: Unable to connect to xend: Connection refused. Is xend running?

then I have to fully restart dom0. This happens every time.

I am using xen of fedora8 distribution with different clients but the problem exists in both cases using a Fedora or gentoo domU.
I post version Info at the end of the mail.

I have tried a lot of things to get hold of what causes the problem:

In domU i tried to copy data from /home (mounted via NFS) into /root.
NO PROBLEM, the error only occurs on copying into /home
dom0(NFS server) <--  domU(NFS client)  PROBLEM
dom0(NFS server)  --> domU(NFS client)  NO PROBLEM

I also tried it the other way round, but this caused no problem:
dom0(NFS client) <--  domU(NFS server)  NO PROBLEM
dom0(NFS client)  --> domU(NFS server)  NO PROBLEM

I also tried to export and mount from localhost for domU and dom0, no problem.
dom0(NFS client) <--  dom0(NFS server)  NO PROBLEM
dom0(NFS client)  --> dom0(NFS server)  NO PROBLEM

domU(NFS client) <--  domU(NFS server)  NO PROBLEM
domU(NFS client)  --> domU(NFS server)  NO PROBLEM

I configured NFS export on some other machine on the network and mounted this export as /home on my domU. There was no problem copying data of any Size in any direction.

It is not only a Problem of copying data into /home the system crashes also if I write Data into /home using cat or dd.

It is not a Problem of access rights, I do all the tests as user root, and as I wrote above the problem only occurs with writes biger then 200 kB. With less it works without any Problem.

I tried to setup the NFS export over the bridge of the external IP Address, but I also set up an only virtual device "virbr0". The Problem occurs in either cases.

I can copy data of any Size from domU to dom0 using scp or netcat.

I cannot believe it, but all the tests show, that this problem only occurs in the one special case described above. Only one direction, only on NFS.

Is this a Bug or am I doing anything obviously crazy that I have overlooked?

Thank you for your response,

Here some Version Info of the dom0 (the problem occurs independently from the domU very different domUs have been tested )

[root@dom0 ~]# /usr/sbin/xm info
release                : 2.6.21-2950.fc8xen
version                : #1 SMP Tue Oct 23 12:24:34 EDT 2007
machine                : i686
nr_cpus                : 2
nr_nodes               : 1
sockets_per_node       : 1
cores_per_socket       : 2
threads_per_core       : 1
cpu_mhz                : 1862
hw_caps : bfebfbff:20100000:00000000:00000140:0000e3bd:00000000:00000001
total_memory           : 2046
free_memory            : 126
xen_major              : 3
xen_minor              : 1
xen_extra              : .0-rc7-2950.fc8
xen_caps               : xen-3.0-x86_32p hvm-3.0-x86_32 hvm-3.0-x86_32p
xen_scheduler          : credit
xen_pagesize           : 4096
platform_params        : virt_start=0xf5800000
xen_changeset          : unavailable
cc_compiler            : gcc version 4.1.2 20070925 (Red Hat 4.1.2-32)
cc_compile_by          : kojibuilder
cc_compile_domain      : (none)
cc_compile_date        : Tue Oct 23 12:22:00 EDT 2007
xend_config_format     : 4

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.