[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Re: calculating the needed swiotlb in dom0

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: "Christopher Isip" <cmisip@xxxxxxxxx>
  • Date: Thu, 29 May 2008 21:18:17 -0400
  • Delivery-date: Thu, 29 May 2008 18:18:49 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=message-id:date:from:to:subject:in-reply-to:mime-version:content-type:references; b=ZivIr8e8cQM0WdxMbNLTCAXCp1TOkw4gcwVr+mmFByArfQbrT9fem9dGtxaYmTGzzun9+LXgRDMJbcCshV2kI+CIGCTlf+L0DVxC66hvRBZL7nWdZmSuncny9SHOgMhzxe01SzaPJ0oEG9xyQhl89myLb16ITxgQ67b9yvHhyDM=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

On Wed, May 28, 2008 at 11:14 PM, Christopher Isip <cmisip@xxxxxxxxx> wrote:

On Wed, May 28, 2008 at 8:30 AM, Christopher Isip <cmisip@xxxxxxxxx> wrote:
I just found out that setting swiotlb=128 in dom0 grub.conf allowed me to run my mythtv domU with additonal options to ivtv:
in /etc/modprobe.d/options
options ivtv enc_mpg_buffers=8

Setting this to any higher value causes a kernel panic.   I want to be able to specify
options ivtv enc_mpg_buffers=16 enc_vbi_buffers=8

How much swiotlb do I need? Is there a way to figure this out or is it just trial and error.


After a bunch of trials, I managed to get mythtv to boot without SW-IOMMU errors and without  kernel panic with the ivtv options set at " options ivtv enc_mpg_buffers=16 enc_vbi_buffers=8" .  I had to specify on the kernel line in dom0's grub.conf : swiotlb=256 and then in the myth domU's grub.conf : swiotlb=128,force.

It would probably work with the dom0 grub swiotlb set at 128 only although I haven't tried that yet.

Hopefully, this will get rid of a bunch of ivtv buffer errors in dmesg.


Well, this afternoon, I decided to work on the xen server directly instead of using ssh through my laptop.  I was suprised to see kernel panics and SW-IOMMU out of space errors again.  I  tried all different configurations I tried last night to no avail.  After about an hour of trying , I thought to myself that the only thing different that I am doing today is that I am not using ssh to connect to the xen server.  I went back upstairs and connected through ssh,  put in the configurations that I knew worked last night, rebooted, reconnected and restarted the mythtv domU and it worked.  I think this is a good bit of information to know that might help anyone else trying to setup a mythtv xen domU.  For some reason, logging in to a machine  physically, causes the SW-IOMMU space to be used.   Perhaps somebody else could enlighten me on what is happening here.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.