[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Latest Xen-unstable with 2.6.30-rc3-tip: All modules missing

No, I just cloned the Xen-unstable repository (= Xen 3.5). Running "make" will automatically download the kernel 2.6.30-rc3-tip.

If you look at the answer from Boris Derzhavets, his solution worked mostly (tutorial at http://bderzhavets.wordpress.com/2009/06/10/setup-fedora-11-pv-domu-at-xen-3-4-1-dom0-kernel-2-6-30-rc6-tip-on-top-of-fedora-11/). At least you can run Xen, but I didn't yet get an answer on how to build a domU kernel in order to run guests... I will have to rebuild them to build the vTPM modules that I want.

Oh, and you should always CC the mailing list if you give replys ;)


For@ll wrote:
Andreas Sommer pisze:

I downloaded Xen-3.5-unstable from http://xenbits.xensource.com/xen-unstable.hg two days ago and built it without problems (make tools, make dist, make install). Well, the /lib/modules/2.6.30-rc3-tip/kernel directory now only contains the subdirectories "arch" and "drivers" - so where are all the other modules??? Of course Xen does not start correctly. It hangs at "Waiting for root file system..." - having no "fs" modules it could be hard to read a file system ;) And by the way: Yes, I created a initrd image for the new kernel (I'm on Debian).

I've also tried to build the Linux kernel under /usr/src/xen-unstable/linux-2.6-pvops.git completely. It then gives me MODPOST errors "ERROR: [xxx.ko] undefined!" for most of the AGP (or AGPGART?) modules. Having removed them, it builds but Xen cannot boot with that kernel.

Any suggestions?

Xen-users mailing list

I read your post and I see are you using xen 3.4-unstable on debian ( lenny ?) and you have the same problem as I, I installed xen-3.4-unstable and used xen kernel from debian lenny 2.6.26-2-xen but when xen is booting I gived error...

[  163.842586] device-mapper: ioctl: 4.13.0-ioctl (2007-10-18)
initialised: dm-devel@xxxxxxxxxx
Begin: Waiting for root file system .... done
^^^^^^^^^ this is a last info from boot, system is waiting waiting
waiting, and after one minute  system output info:

Gave up waiting for root device. Common problems:
ALERT! /dev/sda1 does not exist. Droping to a shell

System go to the BusyBox.

I have a question for you, are you trying using kernel from debian like me 2.6.26-2 with xen 3.4-unstable?


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.