[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] messed up partition table on img file

> If memory serves, pygrub looks for the partition with the grub stuff on 
> it by looking for a partition with the bootable flag set and if it 
> doesn't find one it uses the first partition.   In this case that means 
> it's going to try to boot off the swap partition.
> Try 'a' in fdisk to toggle the boot flag on the second partition.

Tried that. Partition table now looks like:

# /sbin/fdisk -ul disk0
You must set cylinders.
You can do this from the extra functions menu.

Disk disk0: 0 MB, 0 bytes
255 heads, 63 sectors/track, 0 cylinders, total 0 sectors
Units = sectors of 1 * 512 = 512 bytes

 Device Boot      Start         End      Blocks   Id  System
disk0p1              63     1574369      787153+  82  Linux swap / Solaris
disk0p2   *     1574370    83875364    41150497+  83  Linux
Partition 2 has different physical/logical endings:
     phys=(1023, 254, 63) logical=(5220, 254, 63)

When I try to boot it says its "Waiting for device /dev/xvda2 to appear"

I've tried setting the cylinders with fdisk but have had no luck fixing that. 

Other ideas?


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.