[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] xen-tools: does not unmount disks and mounts proc into the new VM - why?

Alexander Menk wrote:

I am using xen-tools version: 3.9-4 to create domUs:

1. time xen-create-image --verbose --dist=lenny
 --hostname dummy --ip xxx.xxx.xxx.xxx --force

2. xm create dummy.cfg

Then I get the message
Device /dev/vg0/dummy-disk is mounted in the privileged domain,
and so cannot be mounted by a guest.

3. When I tried to umount, I got "device busy".

4. I am really surprised about the output of mount on my dom0:

dom0:~# mount
/dev/sda1 on / type ext3 (rw,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
/dev/mapper/vg0-linux--images on /mnt/linux-images type xfs (rw)
/dev/mapper/vg0-xen--file--images on /mnt/xen-file-images type xfs (rw)
/dev/mapper/vg0-dummy--disk on /tmp/1UNYuVP7WO type ext3 (rw)
/proc on /tmp/1UNYuVP7WO/proc type none (rw,bind)

Why is /proc mounted to /tmp/1U.... that is in fact the disk of the new
VM? That looks really dangerous.
Did anybody see this before?

I used --force because on the first call I did a mistake and the logical
volumes already existed. Maybe --force is not a good idea?

I would check to see if a process, like sshd, got started in the chroot that xen-tools created. Having something running there could keep the host from being able to unmount the volumes. I ran into this problem and it was something starting in the chroot. Hope that helps.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.