[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-users] storage is not detected during guest OS install

        Assuming that the log message you found does not indicate an issue,
it would appear that the problem could be that the operating systems you are
trying to install do not have PV drivers.  Try changing this:
disk = [
inst.iso,hdc:cdrom,r' ]
        to this:
disk = [
nst.iso,hdc:cdrom,r' ]
        and then this:
disk = [
st.iso,hdc:cdrom,r' ]
        Note that I am assuming that debmed.img is blank or a partitioned
image, if it is an image that is not partitioned, the above will not work,
but I am not certain that you can provide a partition instead of a disk
image to an HVM domU anyway.

-----Original Message-----
From: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
[mailto:xen-users-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of Barny Kadlecsik
Sent: Wednesday, July 29, 2009 15:52
To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] storage is not detected during guest OS install


I am running Xen (3.2-1-amd64) on Debian (Lenny) and have the following 
problem. I installed Openfiler (from tarball) and works like a charm, 
both with file and logical volume backed storage. However, when I tried 
to run Enterprise Linux (Oracle), no matter how and which kind of 
storage was defined for the guest system, it didn't recognize during 
install. I also tried to install Debian, same problem. Neither logical 
volume, nor file based storage detected during install, so even if both 
of the guest systems are booting flawlessly, practically I'm with a 
diskless system. This is the config file I used with Debian:

name            =       'debmed'
kernel          =       '/usr/lib/xen-3.2-1/boot/hvmloader'
builder         =       'hvm'
bootloader      =       '/usr/lib/xen-3.2-1/bin/pygrub'
memory          =       '512'
disk            =       [ 'file:/xenimagefs/debmed.img,xvda1,w',
'file:/xenimagefs/debian-502-amd64-netinst.iso,hdc:cdrom,r' ]
boot            =       'dc'
vif             =       [ "mac=00:3e:3e:3e:3e:75,bridge=eth0,type=ioemu" ]
on_poweroff     =       'destroy'
on_reboot       =       'restart'
on_crash        =       'restart'
vncdisplay      =       '3'

No useful hints in the logs, except this one (it means nothing to me, 
but maybe rings a bell for somebody):

"I/O request not ready: 0, ptr: 0, port: 0, data: 0, count: 0, size: 0"

This is the last entry after booting the guest OS, I always got this one 
whether I tried to use logical volume as storage, or file. Since I 
almost has no experience with Xen, chances are that I did something 
wrong; all hints/comments are appreciated!


Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.