[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Problem with delegated hardware (Realtek Network driver 8139too)

Edson Marquezani Filho wrote:
On Sat, Feb 27, 2010 at 17:49, Luciano Coutinho Barcellos
<luciano@xxxxxxxxxxxxxxxxx> wrote:
Dear friends,

 I've googled a lot before giving up and come here to ask for some help. All
I've found about my problem was a pretty old single message with no reply
since it was post on Jul 19th, 2007.
 I hope to have better luck and find some light to solve the problem. I want
to configure a domU, with 3 nics (identified as having the Realtek 8139D
chip) delegated to it. Everything works almost great except for the message
shown when I try to ifconfig any card:

      SIOCSIFFLAGS: Cannot allocate memory.

 Considering the following:

     - The cards work fine on dom0;
     - Delegating a card with chipset Via works on domU;
     - Everything is fine with passthrough, card detection and module
loading in domU.

  What could be the problem?
  I've read something about an old b44 driver which suffered from a
limitation about memory allocation. It needed memory from the first physical
16MB. Could it be a similar problem?
  My configuration is the folowing:

     - dom0 kernel command line includes:
     - domU configuration file has: pci = [ '00:08.0', '00:09.0', '00:0a.0'
     - xen hypervisor: 3.2.1-i386 from Debian Lenny repositories
     - linux kernel for both dom0 and domU: 2.6.26-2-xen-686 from Debian
Lenny repositories
     - kernel module used for the nics: 8139too

  Hope to get some help.

I see you are using Debian. Are you aware of what Debian Wiki says
about pci passthrough on Lenny [1]? In few words, it says that it's
possible only if you run kernel 2.6.18 (Etch's one) for both dom0 and
Actualy, I didn't tested it but I assumed it as being true and didn't
even try to configure pci passthroug with kernel 2.6.26.

Anyway, you say it has worked for you and I do believe. =) But, there
may be some issue related to the kernel you are using. I would try
some more "traditional" Xen kernel. =)

Just a clue. I hope this can help you a little bit. =)

[1] http://wiki.debian.org/Xen#Installationonlenny

Thank you very much, Edson. I've just tried with the 2.6.18 kernel from Etch and it just worked. I've manually downloaded and installed the linux-image (http://packages.debian.org/etch/linux-image-2.6.18-6-xen-686) and linux-modules (http://packages.debian.org/etch/i386/linux-modules-2.6.18-6-xen-686/download) from Etch. Now the dom0 shows a lot of 4gb seg fixup messages in console, but that's another question, and I think I can fix it as I've seen about that before.

   Thanks again. Valeu! :)

Attachment: luciano.vcf
Description: Vcard

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.