[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] [solved] Error: pci: 0000:01:07.0: non-page-aligned MMIO BAR found.

Hi Folks,

I make I new approach to pimp up my xen-Kernel in higher version-numbers.
Currently I run a selfcompiled 2.6.27-Kernel from:
hg clone http://xenbits.xensource.com/ext/linux-2.6.27-xen.hg

In the next step I want to run the kernel from jemery:
git clone git://git.kernel.org/pub/scm/linux/kernel/git/jeremy/xen.git

I tried the last couple of days to get pci-passtrough work with jeremys kernel 
but I still get:
chieftec:~# xm create vdr1.cfg
Using config file "/etc/xen/vdr1.cfg".
Error: pci: 0000:01:07.0: non-page-aligned MMIO BAR found.

For quite a long I zero in on the following lines in "xm dmesg":
(XEN) AMD SVM: ASIDs enabled.
(XEN) HVM: SVM enabled
(XEN) HVM: Hardware Assisted Paging detected.
(XEN) AMD-Vi: IOMMU not found! <------ (kernel option iommu=1)
(XEN) I/O virtualisation disabled <----- 
After a while I found out that this errors also could be find in the working 
2.6.27-kernel. So I guess that could not be what caused this mess. :)

While I write this mail I found the solutionâ *DANCING*
So for all who are struggling with this akward error:
-> xen-pciback.hide=(X:XX.X) pci=resource_alignment=XX:XX.X <-
works for me!
title           Xen 3.4.2 /
root            (hd0,6)
kernel          /boot/xen-3.4.2.gz 
module          /boot/vmlinuz- root=/dev/sda7 ro console=tty0 
pci=nomsi noreboot xen-pciback.hide=(01:07.0) pci=resource_alignment=01:07.0
module          /boot/initrd.img-

Now I get:
chieftec:~# xm create vdr1.cfg
Using config file "/etc/xen/vdr1.cfg".
Started domain vdr1 (id=1)

Have a great weekend
GMX DSL: Internet, Telefon und Entertainment fÃr nur 19,99 EUR/mtl.!

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.