[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Re: How to Login to Fedora 11 domU under Debian 5 dom0?

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: Jan Muhammad <janmuhd@xxxxxxxxx>
  • Date: Fri, 19 Mar 2010 12:25:54 +0000 (GMT)
  • Cc: costas.drogos@xxxxxxxxx
  • Delivery-date: Fri, 19 Mar 2010 05:27:16 -0700
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.com; h=Message-ID:X-YMail-OSG:Received:X-Mailer:Date:From:Subject:To:Cc:In-Reply-To:MIME-Version:Content-Type; b=5eCSw7GSM7mHp15cZ56qXWf62v9sMGeucB+DvZAHZDTRzeCYYb1gj3XgihnulNx/oM3lG7eoouBUBNqqyr+Yc9/QTMnfgFb7gnDVysZiO+jZLoCnMYCig83/fYtwpOQ6G/0PqmkKM6KzVAWPIAho/knvr5O+tOSifL6cEn4JhYM=;
  • List-id: Xen user discussion <xen-users.lists.xensource.com>


Sorry for the incomplete command; I do use the # xm console fedora11; but my problem is that I can't find the newly created VM; as I'm in the current directory (/home/xen-testimages) where I have 3 files:


I run the command (#xm create /home/xen-testimages/fedora.11.x86.xen3.cfg).
My problem is, I don't know where the domain fedora11 is being created? I know when I create similar Debian-image(domU); the location goes to /home/xen/domains; but in this Fedora(domU) case where I downloaded the image not created it myself from Xen-create command.
I even created a directory manually on the same location as of Debian domUs but still I'm getting the Error: Domain '/home/xen-testimages/fedora.11.x86.xen3' does not exist."

Thanks for help!

-Jan Muhammad

--- On Fri, 19/3/10, Costas Drogos <costas.drogos@xxxxxxxxx> wrote:

From: Costas Drogos <costas.drogos@xxxxxxxxx>
Subject: Re: [Xen-users] Re: How to create a Fedora 11 domU under Debian 5 dom0?
To: "Jan Muhammad" <janmuhd@xxxxxxxxx>
Cc: xen-users@xxxxxxxxxxxxxxxxxxx, kesha@xxxxxxxxxxxxx
Date: Friday, 19 March, 2010, 16:57

On Fri, Mar 19, 2010 at 13:47, Jan Muhammad <janmuhd@xxxxxxxxx> wrote:
Hi All,

I have downloaded a Fedora 11 Xen image from (http://stacklet.com/downloads/images/lister/Fedora); after un-tar in a directory and changing kernel boot and disk location to look for kernel and image; I created an image with file and I can see the output of the command:
#xm create /home/xen-testimages/fedora.11.x86.xen3.cfg

 "Using config file "/home/xen-testimages/fedora.11.x86.xen3.cfg".
Started domain fedora.11.x86.img"

But when I try to login into the newly created VM with
# xm console /home/xen-testimages/fedora.11.x86.xen3.cfg

The error message says:

Error: Domain '/home/xen-testimages/fedora.11.x86.xen3.cfg' does not exist."

Even copying those Xen cf and image files to the location where my other VMs reside doesn't solve my problem and I get the same error as above.

Any ideas how I can login into the newly created VM? Or what step I'm missing?

My other xen VMs (based on Debian) are located at some other directory and I can easily login to those.

Hello there,

For xm console, you use the hostname, not the config name.
e.g  xm console node1 , not xm console node1.cfg

Costas Drogos

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.