[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Anyone have success with ivtv in a pvm? I got DMA TIMEOUT messages on xen-next/4.0-rc9-pre...

> On Tue, Mar 30, 2010 at 12:36:48AM +0200, Mark Hurenkamp wrote:
>> Hi,
>> For some weeks now, i'm running a xen-4 based system, which i want to
>> take over the tasks of my previous xen-3.2 based server.
>> One of the things i used to do with my 3.2 system, was running a mythtv
>> server inside a pvm with ivtv based hardware. This seemed to work fine
>> with xen 3.2.
>> Trying to get this to work with xen-4, i don't seem to have much
>> success...
>> older versions of the kernel would lock-up (well that's what you get for
>> trying bleeding edge, i know), but now it seems to boot fine.
>> However, as soon as i try to record something from /dev/video0 (e.g.
>> using cat /dev/video0 > tmp0.mpg), i get a ivtv0 DMA TIMEOUT message on
>> my console.
>> When i break off the action (after about 30 seconds or so), the tmp0.mpg
>> file has a 0 size, indicating nothing at all was recorded.
>> Is there something i can do about this? Or am i just asking too much of
>> the system right now? I also tried various swiotlb options (on 3.2 those
>> were absolutely necessary), but to no avail.
>> Any hints/tips would be very much appreciated!
> Maybe this wiki page helps?:
> http://wiki.xensource.com/xenwiki/XenPCIpassthrough

Thanks for your input, i had read this page before, but now noticed there
is one option mentioned there which i had not tried before: iommu=soft.
Tried to boot with that just now, and i don't get the errors anymore, and
the tmp0.mpg file now contains data.
Not sure if everything works ok now, I will do more tests in the course of
this week.
At least I'm one more step closer to running mythtv in domU again!


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.