[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Network problem after updates

Hi all,

I've a serious problem with my dom0 xen installation, that's why I'm blocked to daily work.
I come to describe my virtualization scenary and the arised problem.

Hardware is a Dell server with 3 physicall ethernet network cards and 16 GB RAM.
Initially installed CentOS-5.2 with Xen-3.0.3 and 2.6.18-128.el5xen kernel.
Dom0 with 7 domU paravirtuallized (they have CentOS like os also).
One domU is configured like a Firewall, using one of the physicall NICs through pciback, that directly connect with the ISP modem-router.
Until here all worked ok and I was happy :)

Later, I was made the next updates through "yum update/upgrade" and "yum install Virtualization": Xen 3.4.1 version, CentOS-5.4 and 2.6.18-164.el5xen kernel.
Initially all worked fine, except some stuffs related to bridge name (it came to xenbr0 to eth0).
The problem arise when from certain day, the network was freezed, collapsed.
Anything of the domUs can answer to ping command, except dom0 that is the only I can access via ssh.
Testing some issues, the network recovers if I shutdown the domU Firewall.

I guess that the source of the problem must be pciback kernel module or some incompatibillity with network card driver.
I've configured the xend-pci-permissive.sxp file to fix some messages that appears in the boot of the dom0.

The conclusions that I've get analyzing the situation are the next:
- at the begining, Firewall works ok since it's overloaded by net traffic
- from this moment, exactly 1 hour later from boot/reboot of dom0, the network is blocked...always
- once the network is blocked, if I've shutdown the Firewall, the network recovers
- when much time the network is blocked, more time the Firewall takes to shutdown

Any suggestion?
Thanks in advance.

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.