[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] CentOS5 + PVOPS x86_32 PAE/xen 4rc6 stalls at boot

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: Task Struct From Hell <taskstructfromhell@xxxxxxxxxxxxxx>
  • Date: Mon, 7 Jun 2010 15:56:23 +0100
  • Delivery-date: Mon, 07 Jun 2010 07:58:10 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=googlemail.com; s=gamma; h=mime-version:date:message-id:subject:from:to:content-type; b=Uc8LH9N3QVdSqQx6+Wq8OkEAX78d02/O4dGPGuUra9zKU1jgex9Z1S+c7ATAleyQc2 7egI9YG7MAhBHnjuvn/CATkbTSyv79kfW5c07zykQJzC2s03P7afqKRhvDizQp+i3NRD a8MLRwxIjqyIkW3ZO1ib4hoISQaYhmLyg3MXA=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>


It appears my Xen is stalling right before handing off control to the
dom0 kernel. I would appreciate any pointers on where to look next,
since I've already spent a considerable amount of time trying to
figure this one out and nothing turns up. One small detail, with my
previous .config, I wasn't seeing the  4 "(XEN) MCE: MSR 417 is not
MCA MSR" at the end of the log, but the behavior was the same - no
dom0 boot.

I'm using pasi's .config:

Please note this is the debuggers.hg hypervisor, that's why it's based
on a relatively old version. I'm running this hypervisor successfully
at home. The server is a ~2 years old HP DL 365 g1.with 5gb ram

Any suggestions?


grub config:

title 2.6.32 D2/xen4rc6-dbg
        root            (hd0,0)
        kernel          /xen.gz com1=115200,8n1 console=com1,tty com1=115200,8n1
        module        /vmlinuz-2.6.32-xen
root=/dev/VolGroup00/LogVol00 ro console=tty0 console=ttyS0,115200n8
        module        /initrd-2.6.32-xen

Xen output:

 __  __            _  _    ___   ___               __
 \ \/ /___ _ __   | || |  / _ \ / _ \    _ __ ___ / /_
  \  // _ \ '_ \  | || |_| | | | | | |__| '__/ __| '_ \
  /  \  __/ | | | |__   _| |_| | |_| |__| | | (__| (_) |
 /_/\_\___|_| |_|    |_|(_)___(_)___/   |_|  \___|\___/

(XEN) Xen version 4.0.0-rc6 (root@localdomain) (gcc version 4.1.2 20080704 (Red
Hat 4.1.2-48)) Sun Jun  6 10:29:44 EDT 2010
(XEN) Latest ChangeSet: Fri Mar 19 18:36:57 2010 -0700 20373:809b20f066fb
(XEN) Command line: com1=115200,8n1 console=com1,tty com1=115200,8n1
(XEN) Video information:
(XEN)  VGA is text mode 80x25, font 8x16
(XEN)  VBE/DDC methods: none; EDID transfer time: 2 seconds
(XEN)  EDID info not retrieved because no DDC retrieval method detected
(XEN) Disc information:
(XEN)  Found 1 MBR signatures
(XEN)  Found 1 EDD information structures
(XEN) Xen-e820 RAM map:
(XEN)  0000000000000000 - 000000000009f400 (usable)
(XEN)  000000000009f400 - 00000000000a0000 (reserved)
(XEN)  00000000000f0000 - 0000000000100000 (reserved)
(XEN)  0000000000100000 - 00000000cfe4e000 (usable)
(XEN)  00000000cfe4e000 - 00000000cfe56000 (ACPI data)
(XEN)  00000000cfe56000 - 00000000cfe57000 (usable)
(XEN)  00000000cfe57000 - 00000000e0000000 (reserved)
(XEN)  00000000fec00000 - 00000000fed00000 (reserved)
(XEN)  00000000fee00000 - 00000000fee10000 (reserved)
(XEN)  00000000ffc00000 - 0000000100000000 (reserved)
(XEN)  0000000100000000 - 000000016ffff000 (usable)
(XEN) System RAM: 5091MB (5213312kB)
(XEN) ACPI: RSDP 000F4F00, 0024 (r2 HP    )
(XEN) ACPI: XSDT CFE4ED00, 007C (r1 HP     ProLiant        2   ?^D     162E)
(XEN) ACPI: FACP CFE4ED80, 00F4 (r3 HP     ProLiant        2   ?^D     162E)
(XEN) ACPI: DSDT CFE4EE80, 4FCF (r1 HP         DSDT        1 INTL 20030228)
(XEN) ACPI: FACS CFE4E100, 0040
(XEN) ACPI: SPCR CFE4E140, 0050 (r1 HP     SPCRRBSU        1   ?^D     162E)
(XEN) ACPI: MCFG CFE4E1C0, 003C (r1 HP     ProLiant        1             0)
(XEN) ACPI: HPET CFE4E200, 0038 (r1 HP     ProLiant        2   ?^D     162E)
(XEN) ACPI: SPMI CFE4E240, 0040 (r5 HP     ProLiant        1   ?^D     162E)
(XEN) ACPI: ERST CFE4E280, 01D0 (r1 HP     ProLiant        1   ?^D     162E)
(XEN) ACPI: APIC CFE4E480, 007E (r1 HP     ProLiant        2             0)
(XEN) ACPI: SRAT CFE4E580, 0110 (r1 AMD    HAMMER          1 AMD         1)
(XEN) ACPI: FFFF CFE4E980, 0176 (r1 HP     ProLiant        1   ?^D     162E)
(XEN) ACPI: BERT CFE4EB00, 0030 (r1 HP     ProLiant        1   ?^D     162E)
(XEN) ACPI: HEST CFE4EB40, 0170 (r1 HP     ProLiant        1   ?^D     162E)
(XEN) Memory to Node hash needs 5889 entries, got only 64
(XEN) SRAT: No NUMA node hash function found. Contact maintainer
(XEN) SRAT: SRAT not used.
(XEN) Xen heap: 8MB (8832kB)
(XEN) Domain heap initialised
(XEN) Processor #0 15:1 APIC version 16
(XEN) Processor #2 15:1 APIC version 16
(XEN) Processor #1 15:1 APIC version 16
(XEN) Processor #3 15:1 APIC version 16
(XEN) IOAPIC[0]: apic_id 8, version 17, address 0xfec00000, GSI 0-15
(XEN) IOAPIC[1]: apic_id 9, version 17, address 0xfec01000, GSI 16-31
(XEN) Enabling APIC mode:  Flat.  Using 2 I/O APICs
(XEN) Using scheduler: SMP Credit Scheduler (credit)
(XEN) Detected 2200.177 MHz processor.
(XEN) Initing memory sharing.
(XEN) HVM: ASIDs disabled.
(XEN) HVM: SVM enabled
(XEN) AMD-Vi: IOMMU not found!
(XEN) I/O virtualisation disabled
(XEN) AMD: Disabling C1 Clock Ramping Node #0
(XEN) AMD: Disabling C1 Clock Ramping Node #1
(XEN) Total of 4 processors activated.
(XEN)  -> Using new ACK method
(XEN) checking TSC synchronization across 4 CPUs:
(XEN) CPU#0 had -1945586 usecs TSC skew, fixed it up.
(XEN) CPU#1 had -1952257 usecs TSC skew, fixed it up.
(XEN) CPU#2 had 0 usecs TSC skew, fixed it up.
(XEN) CPU#3 had -1952257 usecs TSC skew, fixed it up.
(XEN) Platform timer is 14.318MHz HPET
?(XEN) Brought up 4 CPUs
(XEN)  Xen  kernel: 32-bit, PAE, lsb
(XEN)  Dom0 kernel: 32-bit, PAE, lsb, paddr 0x400000 -> 0xae9000
(XEN)  Dom0 alloc.:   000000003c000000->000000003e000000 (1255880
pages to be allocated)
(XEN)  Loaded kernel: c0400000->c0ae9000
(XEN)  Init. ramdisk: c0ae9000->c1176800
(XEN)  Phys-Mach map: c1177000->c1649720
(XEN)  Start info:    c164a000->c164a47c
(XEN)  Page tables:   c164b000->c165c000
(XEN)  Boot stack:    c165c000->c165d000
(XEN)  TOTAL:         c0000000->c1800000
(XEN)  ENTRY ADDRESS: c08ac000
(XEN) Dom0 has maximum 4 VCPUs
(XEN) Scrubbing Free RAM: .done.
(XEN) Xen trace buffers: disabled
(XEN) Std. Loglevel: Errors and warnings
(XEN) Guest Loglevel: Nothing (Rate-limited: Errors and warnings)
(XEN) *** Serial input -> DOM0 (type 'CTRL-a' three times to switch
input to Xen)
(XEN) Freed 132kB init memory.
mapping kernel into physical memory
Xen: setup ISA identity maps
about to get started...
(XEN) MCE: MSR 417 is not MCA MSR
(XEN) MCE: MSR 417 is not MCA MSR
(XEN) MCE: MSR 417 is not MCA MSR
(XEN) MCE: MSR 417 is not MCA MSR

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.