[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] crash e100 amd64 >=4GB RAM

Am 27.05.2010 07:32, schrieb Claudiu CurcÄ:
On Thu, May 27, 2010 at 8:19 AM, Daniel Schmitt<daniel.schmitt@xxxxxxx>  wrote:

Hello list,

I'm using gentoo Linux with xen 3.4.1 and linux kernel 2.6.30 fine till
now where I need more RAM. I used 2GB and now I want to use 4GB.
But upping eth0 (4-port e100 Quad Port Device by Compaq) crashed the
kernel. I tried xen 4.0.0 with linux kernel 2.6.32-r1 from
http://code.google.com/p/gentoo-xen-kernel/downloads/list same error.
Using swiotlb=force or swiotlb=128,force or iommu=off did not succeed
even. The board has a tg3 gigabit NIC eth4, too. Upping this device does
not crash the kernel.
It must have something to do with e100 driver.
The machine where the crash happens is a Dell PowerEdge 840. It uses Intel
Core2Duo (dual core).

Can anyone help?

Here is some crash information:
kernel BUG at lib/swiotlb-xen.c:454!
[<ffffffff80481120>] e100_rx_alloc_skb+0x190/0x230
RIP [<ffffffff803c56a6>] swiotlb_sync_single_for_device+0x96/0xe0
Segmentation fault


Does it happen with a non-xen (sys-kernel/gentoo-sources) kernel too?
(linux-2.6.32-gentoo-r7 is the latest, I believe).
If it does, then this could surely be a problem in the e100 driver and
should be reported upstream.

I tried now with grml 2010-04 amd64 version.
It does not hang. Upping eth0 works. Network traffic is received but not answered. ARP Replies are sent to the wrong IP if an ARP Request is received. I analysed this with tcpdump. Beside this, no packet is sent! If I try to ping another station, the TX packets counter does not get increased.

strange ...

Seems like e100 is broken with amd64?
Perhaps I manage to use plain old eepro100 by D. Becker.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.