[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Problem with grub2 and xen (Ubuntu 10.04)

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: Thomas Richard <thomas9999@xxxxxxxxx>
  • Date: Wed, 16 Jun 2010 18:12:02 +0200
  • Delivery-date: Wed, 16 Jun 2010 09:13:32 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:date:message-id:subject:from:to:content-type; b=Dk7aQLzqNeb5CRejuegXgeF0cStbrurbqBRmTZLnSkYaV4cgvOl962sNMJPwf9tC94 wZn1Isfa+HxcWmZC29ETDiw5tM6ZnRptbrQ3GMTUIjq47cNEeES/+Z2u6VXxCIznQHLc 6NyCYiXIehwr4ieSh/NIAblY4oYAbXdN6+q7Y=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Hey all,

I tried to install xen 4.0.1-rc3pre on my ubuntu installation. The
installation seemed to work. I also compiled my own dom0 kernel
( The kernel works perfect when i boot it without xen.
However, when i want to start the xen hypervisor i get the following
error from grub: "Error: couldn't open file", followed by some lines
that say that the multiboot kernel should be loaded first.

This is my menu entry:
menuentry "Xen 4 / Ubuntu 10.04 kernel" {
insmod ext2
set root='(hd2,2)'
multiboot (hd2,2)/boot/xen.gz /boot/xen.gz
module (hd2,2)/boot/vmlinuz- dummy=dummy nopat
root=/dev/sdc2 ro console=tty0 ro console=tty0
module (hd2,2)/boot/initrd.img-

I'm pretty sure that hd2,2 is correct as booting the linux kernel with
that drive as root works. I also tried without the /boot but that
didn't help. Does anyone have an idea what causes this problem?

Thomas Richard

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.