[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Problems with xen and linux 2.26.32 kernels

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: Jia Rao <rickenrao@xxxxxxxxx>
  • Date: Wed, 16 Jun 2010 14:51:09 -0400
  • Delivery-date: Wed, 16 Jun 2010 11:52:43 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:date:message-id:subject:from:to:content-type; b=AexVRy4viwt5/kRJfBd3qgShclFCrsBoRVrLTx0c3dwgoTFJS0H2N77vnEsyqa1rpj wvKaFemfZbYX6R+b+VNSt+8Xca3Nk5Uxi+XpBD6jTRU63UcvUN3s9ykAKnUscyAwZvDY 9jW7/5HRCKlS+6/0IhjdoJyUwRW2fb3TSAzvc=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Hi all,

I used to use xen 3.4.2 and linux 2.6.18-xen kernels for both dom0 and domU, without any problems.

Recently, I need to try io bandwidth control like dm-ioband in the new kernel 2.6.32 (dm-ioband has patches for this kernel). It gave me a lot of problems if I want to upgrade the dom0 to 2.6.32. The following is what I tried and the errors.

Xen: 3.4.3 (I need to stick with 3.4.x. 3.4.3 is the one that can run pvops)

First approach:
I tried to download pvops from the git repository xen/stable-2.6.32.x. The compilation was OK, but the initrd has a lot missing dependencies. I tried to use --builtin to claim those missing modules in kernel. However, with the generated initrd, dom0 can not boot. I got the error: unable to locate IOAPIC for GSIx and mount: could not find filesystem: /dev/root.
I enabled : CONFIG_SYSFS_DEPRECATED=y,  CONFIG_SYSFS_DEPRECATED_V2=y and tried to use root=/dev/sdax or root=LABEL=/. No luck.

Second approach:
Then I switched to the forward ported kernel generated from the gentoo xen kernel patches.

Still xen 3.4.3. After compilation, dom0 booted successfully. However I previous domU which has 2.6.18-xen kernels can not boot. It has the same error: mount: could not find filesystem: /dev/root
Do I need to create a initrd for the domU? I didnt need one when dom0 is 2.6.18-xen kernel.

BTW. I dont see a PARAVIRT_GUEST config option in the forward ported 2.6.32 kernel.

Any ideas?
Thanks in advance!

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.