[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Complete Xen n00b getting stuck trying to create a VM

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: Ewan Slater <ewan.slater@xxxxxxxxxxxxxx>
  • Date: Mon, 21 Jun 2010 19:21:25 +0100
  • Delivery-date: Mon, 21 Jun 2010 11:24:05 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=googlemail.com; s=gamma; h=mime-version:date:message-id:subject:from:to:content-type; b=OnaMJFULV3t137mcnL9YpNaggLG4g0uBSGseudyuUUy5zJ91w3s8+hp8Qy3GN6N/xQ KwQf2hnHw3HFUzitiF09O48O1x5xQL6d3tEOgSFtcd8eBOo3ExzE5zQkVxZJDPyFdTrr UON3N8+wNagSYtm/9njRh/MczF468+33TAgtc=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>


I've installed CentOS 5.5 with the virtualisation option.

I have also put a copy of the CentOS 5.5 .iso on the filesystem.

I then try to create my first vm with virt-install --prompt, and give
the path to the .iso for CentOS.

Then terminal window runs through to "Creating domain" and the virt
viewer opens and asks me what type of media contains the packages to
be installed.

How can I get it to read the .iso that I specified on the command line?

I have tried exporting the directory containing the .iso through NFS,
I've checked I can mount the directory via NFS and then tried to use
this but no dice ("That directory could not be mounted from the
server").  I then tried mounting the .iso as a directory on the host
file system, and exporting that directory via NFS, but got the same

What I would ideally like to do is to tell the VM I'm creating that it
has a CD/DVD-ROM attached and to point it to the .iso file.

Any help would be most gratefully received.



Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.