[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] RE: blktap2 does not work

  • To: darkbasic4@xxxxxxxxx, xen-users@xxxxxxxxxxxxxxxxxxx
  • From: eXeC001er <execooler@xxxxxxxxx>
  • Date: Wed, 23 Jun 2010 18:07:57 +0400
  • Cc:
  • Delivery-date: Wed, 23 Jun 2010 07:09:17 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:date:message-id:subject:from:to:content-type; b=E9QsFtz2vlecZ0NtAt445RcLxC5rvohlRi8X13lU0gWTOz80eHCiEq7prX4tN//vKm /Vw8qg1wFEsimCqxnRiFi7ljWwi2JJJ2WOl8LgwVMOOy+sJ1dD/4TCuVE1oSwpVhgdmn hkG902YSxalAGelP5LkE5a0lzHQe8dsaYoVCA=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Distro: debian unstable
Xen version: 4.0.0-2

This is the config:
#still no qemu-dm in debian

#kernel = "/usr/lib/xen-4.0/boot/hvmloader"
#builder = 'hvm'
#memory = 2048
#name = "webserver"
#vif = ['bridge=eth0']
#disk = ['tap:tapdisk:aio:/srv/xen/webserver.img,xvda,w','phy:/dev/cdrom,xvdb:cdrom,r']
#device-model = '/usr/lib/xen-4.0/bin/qemu-dm'
#vnc = 1
#boot = 'd'


name = "webserver"
memory = 2048
bootloader = "/usr/lib/xen-4.0/bin/pygrub"
vif = ['bridge=eth0']
disk = [ "tap:tapdisk:aio:/srv/xen/webserver.img,xvda,w" ]
vnc = 1

When I run xm create /srv/xen/profiles/webserver.cfg I get:
Using config file "/srv/xen/profiles/webserver.cfg".
Error: [Errno 2] No such file or directory: 'aio:/srv/xen/webserver.img'

I created the image with dd:
# dd if=/dev/zero of=/srv/xen/webserver.img oflag=direct bs=1M seek=4095 count=1
# dd if=/dev/zero of=/srv/xen/webserver.img oflag=direct bs=1M count=4096


blktap2 works in current xen-testing-4.x and xen-unstable, but you should be use tap2:tapdisk:aio:...... (I do not know why it is not displayed in the documentation,Âbut the code works the way).Â

My configuration: "Opensolaris + pygrub + VHD" work fine for me.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.