[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] How to change default interface from eth0 to eth3?

  • To: Mark Adams <mark@xxxxxxxxxxxxxxxxxx>
  • From: Juan Pablo Lopez Bergero <lopezjp@xxxxxxxxx>
  • Date: Fri, 3 Sep 2010 10:41:09 -0300
  • Cc: xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Fri, 03 Sep 2010 06:43:02 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:from:date:message-id:subject:to :cc:content-type; b=RB+q0Zw5bjM6xyA7mHZ9ZyJufGiUao+O8knizAbO/QPLoZiPh4AYzJCD0tMjKHFvMf qKoXntY6Q8952/98s5c6yjK4FLP62NO5I7pijXlv+sWJuiGjAXdR9U5GTa5YPrNXCsMi rk1Gy7i6WpJ66crkXCnl931My2go2opPmcGZg=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Solved. I run /etc/xen/scripts/network-bridge and then list then, and then change in the config file of the vm to eth3 (listed in network bridge as a bridge)


On Fri, Sep 3, 2010 at 8:00 AM, Mark Adams <mark@xxxxxxxxxxxxxxxxxx> wrote:
Your bridge isn't called xenbr0 then. Use brctl show to find out what it's
called, then put bridge=whatever in your vif ='' line.

if your trying to change the interface used for the bridge (the default
will normally be used) then you need to change /etc/xen/xend-config.sxp
line (network-script 'network-bridge netdev=whatever')

On Thu, Sep 02, 2010 at 11:16:35AM -0300, Juan Pablo Lopez Bergero wrote:
> I got this message when i'm trying to create the VM.
> Error: Device 0 (vif) could not be connected. Could not find bridge device
> xenbr0
> Is there a way to change de interface from eth0 to eth3?
> thanks
> --
> *-----*
> *Juan Pablo Lopez Bergero*
> *Cell: 15-3957-3455*
> *
> *

> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users

Juan Pablo Lopez Bergero
Cell: 15-3957-3455

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.