[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] xen upgrade problem, cant boot from 3.4.2 to 4.0.0

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: Daniel <dandadude@xxxxxxxxx>
  • Date: Thu, 9 Sep 2010 10:43:58 +0200
  • Delivery-date: Thu, 09 Sep 2010 01:46:24 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :content-type; b=BE/q5uSvxy+JJ5PjT/p4fRY054O4KAIccoNLPxmma/o8YHaBnOC3bBHTe+fnBlHVQh f6q68BhdRQPh8ayh6u154l7uyHZkQmqIQbh8DL5FJ9bgH2VGG+JqaehaVz0QzJPjmVf8 DmBm0Va3dJRBjQS6Rgo9tNPDALiGyUblGMjGU=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Hi Fajar!
THanks for replying!
What you write can't be the problem, since the same configuration and xen/kernel works great on a freshly installed IBM server with 100% identical hardware and configuration.
I have tried with an older kernel, but also tried with a newer one which I have compiled right before upgrading. The kernel I am trying now is "2.6.34-xen-r3" with xen-4.0.0.
In portage these are the most recent xen and kernel ebuilds, which work great on the other server.
I have installed xen-4.0.0 on other servers also freshly, no problem there, only with upgrading, and that is on all servers I have tried to upgrade ;-(
Any other suggestion?

2010/9/9 Fajar A. Nugraha <fajar@xxxxxxxxx>
On Thu, Sep 9, 2010 at 1:03 PM, Daniel <dandadude@xxxxxxxxx> wrote:
> Hi Guys!
> I have a very interesting problem.
> I run gentoo and have been running xen-3.4.2 on 2 server computers
> (Supermicro-based, IBM).
> A little time ago, I have tried to upgrade xen-3.4.2 to xen-4.0.0 (with
> emerge) on the Supermicro server, but the computer wasn't able to boot

> - If I set xen-3.4.2.gz in the grub (with installed xen-4.0.0), it is able
> to boot normally, only xend does not start (but I don't need a livecd). This
> means that there is no problem with the kernel, only xen-4.0.0 is the fault
> ;-)

> What do you recommend?

Short version: it's easier to copy what others have succefully done,
and copy it. Hopefuly other Gentoo users can share their experience.

Long version: I haven't used gentoo in a long time, but my guess is
that you run into some xen-and-kernel compatibility problem.
You might want to to update your kernel as well, and/or use Xen 4.0.1.

For comparison, In RHEL/Centos5, the following combination works:
- bundled xen (3.1+) with bundled kernel-xen (2.6.18 + RHEL patches)
- newer xen 3.x (up to 3.4.3, preferably from Gitco repo) with bundled
- Xen 4.0.0 with kernel 2.6.34 +

while using Xen 4.0.0 + RHEL's kernel-xen does not work. I haven't
tested 4.0.1 yet. Also, pv_ops kernel currently require a matching
version of xen, so if you use latest pv_ops kernel for dom0, make sure
you also use latest xen version (4.0.1 or latest xen-testing).


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.