[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Re: [Xen-users] dom0 hangs in xen 4.0.1-rc3-pre

  • To: Andreas Kinzler <ml-xen-devel@xxxxxx>
  • From: Bruce Edge <bruce.edge@xxxxxxxxx>
  • Date: Wed, 29 Sep 2010 11:01:27 -0700
  • Cc: xen-devel@xxxxxxxxxxxxxxxxxxx, xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Wed, 29 Sep 2010 11:03:12 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type; b=EtGTmqRd2SJstptYtWvUlsffu/naALfl/F+6PTFnJhkWsBm2o4GCA6WjEWhbboe/6r pmnjtNMtWAsa2VZ1W+PWNq/dUImXsPwqjTaA67O95HYh9dyq51M3wuLD3+8I7626tWlQ XeUbb5b72cn1kbjsH4lYtCqJIF2+vYB5/fpfQ=
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>

On Wed, Sep 29, 2010 at 10:46 AM, Andreas Kinzler <ml-xen-devel@xxxxxx> wrote:
> On 28.09.2010 18:04, Bruce Edge wrote:
>>>>> I am still researching this. For testing I bought a test system with
>>>>> Westmere-EP (Xeon E5620) which has ARAT. This system worked stable
>>>>> while
>>>>> Intel still lists it as having the C6 errata. This leads me to the
>>>>> conclusion that the HPET timer migration code (called HPET broadcast)
>>>>> from
>>>>> Xen is the root cause. This affects all CPUs that use it - but mainly
>>>>> Nehalem because of turbo mode.
>>>> Thanks for the info. I'll try disabling turbo mode in the BIOS and see
>>>> if
>>>> that helps.
>>>> Let me know if there's anything I can run/do/test/etc.
>>> If you want to check the issue I am referring to then you need to apply
>>> my
>>> patch from:
>>> http://lists.xensource.com/archives/html/xen-devel/2010-09/msg00556.html
>> Andreas,
>> With this patch the dom0 hangs when I start the vm in pv mode. The hvm
>> ISO based install was OK, but the pv mode runtime hung the dom0
>> shortly after the boot entry was selected from the VM's grub menu.
>> There was no output on the VM console.
>> The dom0 console is printiing these:
>> [38927.441493] BUG: soft lockup - CPU#0 stuck for 61s! [swapper:0]
>> [38992.941432] BUG: soft lockup - CPU#0 stuck for 61s! [swapper:0]
>> [39058.441434] BUG: soft lockup - CPU#0 stuck for 61s! [swapper:0]
>> [39123.931432] BUG: soft lockup - CPU#0 stuck for 61s! [swapper:0]
> Please try this dom0 kernel:
> http://git.kernel.org/?p=linux/kernel/git/jeremy/xen.git;a=snapshot;h=e6b9b2cbca5093e8e38d3e314e2f6415ad951c60;sf=tgz


Is that a 2.6.18 snapshot (as indicated by your .config name) ?

That one worked for me too, it wasn't until I started using 2.6.21
that I started having these problems. And, while it's tempting to
stick with .18, I need to track the active development for a number of

Also, the hang I mentioned wasn't related to your patch. The .21 hangs
without it as well.

Since .23 was just pushed out, I'll retry with that, with and without
your patch.

Thanks for the help.


> I have also attached the kernel config for it that is working for me.
>> And lastly, just for confirmation, this it the patch I applied:
> Yes. This is the patch I mean.
> The kernel mentioned above and my patch gives me a system that works quite
> well on my machines.
> Regards Andreas

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.