[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Unable to run susestudio XEN domU on older dom0 machine

  • To: <xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: Adam Kurzawa <kurzawa@xxxxxxxxxxx>
  • Date: Wed, 13 Oct 2010 21:13:17 -0400
  • Delivery-date: Wed, 13 Oct 2010 18:14:48 -0700
  • Importance: Normal
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

I have build an appliance sing the susestudio tool. It seem to work in their test environment, however, it will not run on my dom0 machine. The test machine is over 3 years old, so I am worndering if there are any incompatibilities.
xm info on the dom0 returns this:
release                :
version                : #1 SMP Tue Feb 13 09:35:18 UTC 2007
xen_major              : 3
xen_minor              : 0
xen_extra              : .2_09763-0.8
xen_caps               : xen-3.0-x86_64 hvm-3.0-x86_32 hvm-3.0-x86_64
platform_params        : virt_start=0xffff800000000000
xen_changeset          : 09763
cc_compiler            : gcc version 4.1.0 (SUSE Linux)
cc_compile_by          : abuild
cc_compile_domain      : suse.de
cc_compile_date        : Fri Oct  6 15:58:46 UTC 2006
The .xenconfig file generated by the susestudio is as follows:
#  -*- mode: python; -*-
disk=[ "tap:aio:vmunison.x86_64-0.0.1.raw,xvda,w" ]
vif=[ "bridge=xenbr0" ]
I edit the file to use absolute paths and attempt to start it up. I get this:
Error: No kernel specified
So now I play around, add the "bootloader = '/usr/bin/pygrub'" line. It returns the message "Error: too many values to unpack".
My existing vms use the "bootloader = '/usr/lib/xen/boot/domUloader.py'" line, so I tried that, still the same problem.
If I change the "tap:aio" to "file", then I get the boot loader to display one page of text and then it crashes.
Is there any hope in getting it runnig on the existing dom0?
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.