[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Named in domu listening on only some IP addresses

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: "David Dyer-Bennet" <dd-b@xxxxxxxx>
  • Date: Thu, 28 Oct 2010 13:16:34 -0500
  • Delivery-date: Thu, 28 Oct 2010 11:17:32 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=dd-b.net; h=message-id :in-reply-to:references:date:subject:from:to:mime-version :content-type:content-transfer-encoding; q=dns; s=dd-b.net; b=QE V1GWWHp2FoQMuJmjDcZrs2skV+O8uvDCqMA+kju3mo9db1eeVSVgtWr9ZCdazAHr Jk9Vh16s3Zp0mYPtNPduaGmyJJiuQ/6XSExiktBSp72R5xF0Y3wwjg67iLrL4All 32WqLHdtcFAabKjCK19hMnPvhJwaS4SV6TNrMER0I=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

On Thu, October 28, 2010 12:10, Simon Hobson wrote:
> David Dyer-Bennet wrote:
>>I just noticed that the named instance I have running in my dom0 is only
>>listening on some addresses.
>>Netstat -ln shows the following relevant listeners:
>>tcp  0      0*                   LISTEN
>>tcp  0      0*                   LISTEN
>>tcp  0      0*                   LISTEN
>>tcp  0      0 ::1:53                :::*                        LISTEN
>>tcp  0      0 ::1:953               :::*                        LISTEN
>>udp  0      0*
>>udp  0      0*
>>udp  0      0 ::1:53                :::*
>>What's missing from this list is -- the primary IP for the
>> dom0!
> What happens if you stop and start the service (not reload or
> restart) after starting Xen and any guests ?
> If it's still the same then I'd say you need to look at the config -
> does the OS have a file for declaring startup options ?
> I don't think this is anything to do with ACLs in your BIND config -
> if (for example) you specify an "allow-query" clause, that doesn't
> control which interfaces/IPs the service will listen on.

I played with allow-query and listen-on clauses, and wasn't getting anywhere.

However, I had the brilliant idea of completely uninstalling the packages,
and reinstalling, and THAt cleaned things up.  (It was messed in a couple
of ways, and more complicated than I thought; the Centos (meaning RedHat
EL) init file copies things from /etc to /var/named/chroot/etc and does
other interesting things, and some of that was broken somehow.

> If stopping/starting the service brings it up on all interfaces/IPs,
> then perhaps something isn't ready at the time BIND starts.

Good thought, but I'd tried stop/start sequences while changing the
config, and they didn't get it up right.  (I hadn't thought specifically
of testing for that sort of timing problems, but it happened
coincidentally with other things I was trying.)

All good now!  Thanks for the suggestions.

David Dyer-Bennet, dd-b@xxxxxxxx; http://dd-b.net/
Snapshots: http://dd-b.net/dd-b/SnapshotAlbum/data/
Photos: http://dd-b.net/photography/gallery/
Dragaera: http://dragaera.info

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.