[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Problems with VM migration

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: Deborah Maria Vieira Magalhães <deborah.vm@xxxxxxxxx>
  • Date: Fri, 5 Nov 2010 10:25:09 -0300
  • Delivery-date: Fri, 05 Nov 2010 06:26:51 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :content-type; b=vJwWbU85XQkIwok/JNxfosS1OSsql+qQrLu+lwGubMkRBMYZ2mLu4xGeEdadCWp7GW Lttb24+E2ytnnR7xKD6gLDKLHFSg1OjWfwOTBLimiI9bHsUV4D6eBDWwskQfx8fy1QOR WoJfimAYg6g3HSu4a43Iko+DVQby8xQxXILQg=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

2010/11/4 Deborah Maria Vieira MagalhÃes <deborah.vm@xxxxxxxxx>
Hi George,

Thanks for your help. There's something really odd with this. I tried what you said, but the error didn't disappear. Then, with the VM stopped (because of the failed migration) I started it on Host2, then tried migration and it worked. So, I'm a bit confused here. Well, if something strange occurs again I'll post it.


2010/11/4 George Shuklin <george.shuklin@xxxxxxxxx>

try to restart xapi toolstack /opt/xensource/bin/xe-toolstack-restart
(first - on master, later (about after 10 sec) on slaves), wait about
30s and retry.

Ð ÐÑÐ, 04/11/2010 Ð 14:07 -0200, Deborah Maria Vieira MagalhÃes ÐÐÑÐÑ:
> I have Host1 and Host2. When I try to migrate a VM from Host2 to Host1
> with the command
> Â xe vm-migrate uuid=6b6f923b-b2de-e5de-a429-aae682552c32
> host-uuid=93fee58a-ca14-4189-a56f-efd8dd83b2c7 --live
> I get the following error
> Â Error: No matching VMs found
> Surely I verified the uuid with xe vm-list.
> The odd thing is when I try to migrate from Host1 to Host2 with the
> command
> Â xe vm-migrate uuid=6b6f923d-b2de-e5de-a429-aae682552c32
> host-uuid=88e429cf-eb1f-4c80-83b6-66772554e70a --live
> I get this
> Â An error occurred during the migration process.
> Â vm: 6b6f923d-b2de-e5de-a429-aae682552c32 (xcp-vm-ubuntu64)
> Â source: 93fee58a-ca14-4189-a56f-efd8dd83b2c7 (xcp-resource01)
> Â destination: 88e429cf-eb1f-4c80-83b6-66772554e70a (xcp-resource02)
> Â msg: Caught exception INTERNAL_ERROR:
> [ Xapi_vm_migrate.Remote_failed("unmarshalling error message from
> remote") ] at last minute during migration
> Can anyone help me with that? I don't know what to do.
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.