[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] issue moving guest from 3.2 to 4.01

On 12/23/2010 02:59 AM, chris wrote:
> Hello,
> I have a pv linux guest which works perfectly on 3.2 and when I moved
> the guest to the new server (debian squeeze, xen 4.0.1) I cannot start
> it, I get the following error:
> # xm create vm-customer.cfg
> Using config file "./vm-customer.cfg".
> Error: (1, 'Internal error', 'launch_vm: SETVCPUCONTEXT failed (rc=-1)\n')
> here is my domain config:
> http://pastebin.com/FEw9k9dr
> I assumed that it was due to the domU kernel not being compatible with
> the hypervisor so i replaced them with the domU kernel from squeeze
> but I still get the same error.
> A quick google returns a post about someone starting 100 domains and
> this occuring on the 101st domain, however in this case this is the
> first vm im putting on this machine so I don't think it is related.
> Has anyone had this issue? Any idea how I can debug this? I tried
> setting vcpus=1 and cpus=1 just to see if it wanted those directives
> but it doesnt seem to make any difference
Your VM is using sda1. Switch to the new device name system: xvda1.
Then you might have a chance to have it working... :)


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.