[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Can't find root when start vm

I can't start Virtual Machine, have the message:
 Waiting for root file system ... done.
Gave up waiting for root device.  Common problems
ALERT!  /dev/xvda2 does not exist.  Dropping to a shell!

I have installed Xen 4 in a debian squeeze:
# uname -a
2.6.32-5-xen-amd64 #1 SMP Wed Jan 12 05:46:49 UTC 2011 x86_64 GNU/Linux

xen-hypervisor-4.0-amd64                4.0.1-2                     The
Xen Hypervisor on AMD64

I have created the virtual machine with this command:
# xen-create-image --size=2Gb --swap=128Mb --dhcp --dist=stable
--dir=/home/xen --hostname=debian

My debian.cfg is:
kernel      = '/boot/vmlinuz-2.6.32-5-xen-amd64'
ramdisk     = '/boot/initrd.img-2.6.32-5-xen-amd64'
vcpus       = '1'
memory      = '128'
root        = '/dev/xvda2 ro'
disk        = [
on_poweroff = 'destroy'
on_reboot   = 'restart'
on_crash    = 'restart'

In my Server the filesystem is /dev/sda1.
I have tried with:
root        = '/dev/xvda1 ro'
root        = '/dev/sda1 ro'
root        = '/dev/sda2 ro'

And the same problem

In the /dev vm I have:
(initramfs) ls /dev
char console core cpu_dma_latency fd full hvc0 hvc1 hvc2 hvc3 hvc4 hvc5
hvc6 hvc7 input kmsg mapper mem network_latency network_throughput null
port psaux ptmx pts random snapshot ttyx urandom vcs vcs1 vcsa vcsa1
vga_arbiter xen zero

I have tried with vcs vcs1 vcsa vcsa1 but have the error:
mount: mounting /dev/vcs1 on /root failed: No such file or directory

Any idea? I'm making wrong something?

A lot of thanks!

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.