[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Debian dom0 Centos domU network xenbr0 and VNC problems


I'm new to this list and a first time user of Xen. I've been playing around with Xen now for about two weeks and ran into some problems. Sorry for the long post, please bear with me.

First I tried running a dom0 environment from CentOS. I followed this tutorial (http://goo.gl/toOE0) and got a CentOS domU running. I also tried following this tutorial (http://goo.gl/K9wj7) but I could not connect to the VNC server. I found out that Debian 6 had the latest version of Xen as a package. As I'm more familiar with Debian I figured I would rather have a Debian dom0 environment. So I read the following page (http://wiki.debian.org/Xen) and some links to get myself familiar with the Debian method.

I successfully installed the dom0 kernel and it seems to be working. I got two Dell PE860 servers at home with HVM support for testing. On the first one I still have my CentOS dom0, on the second one I now have the Debian dom0. I gave each VPS its own logical volume on the LVM. I created the following partition layout on a 160 GB hard disk drive.

* /boot (256 MB)
** swap (4 GB)
** / (16 GB)
** vps1 (32 GB)

I want to have a CentOS domU on my Debian dom0 server. First off I could not find a HVM example in "/etc/xen" so I grabbed the one from my CentOS dom0 and used that one. When I tried to boot up I got an error and looked in to the logfile "/var/log/xen/qemu-dm-vps1.log". This had the following (http://pastebin.com/cdTEKdut) contents. I looked up the error and found some references to it on several sites. It seems that the "/etc/xen/xend-config.sxp" did not have this line in it: "(network-script network-bridge)". Also the networking bridge script did not start out of itself after a reboot. So I ran "/etc/xen/scripts/network-bridge start".

I compared both Xen configuration files from my CentOS dom0 and Debian dom0 and put line back in the configuration file. When I now do "ifconfig -a" I get the following output (http://pastebin.com/VHYswjhH) on my Debian dom0 and this (http://pastebin.com/ktWZ6QZA) on my CentOS dom0. So xenbr0 is not present on my Debian dom0. I searched some more I found that eth0 should now be my virtual network adapter. Is this correct? Also is this the recommended method of fixing this problem? I also read something about using native Debian network bridging. Should I switch to that?

Now on the VNC problem. I finally got my CentOS domU started up. Here you can find the configuration file which I used (http://pastebin.com/v7rCWX2E). I'm trying to boot a CentOS network installation using VNC. The server is in my LAN and I basically used the tutorial from the Virtuatopia website. I verified VNC was running by entering this command "ps -ef | grep vnc" and got the following output (http://pastebin.com/QcS0J6c3). There are a few errors in the log file (http://pastebin.com/DdPXrFQ4) but I'm not sure if they related to the VNC problem.

Then I tried connecting to and from my workstation over the LAN using TightVNC Viewer but I could not connect. Could someone help me troubleshoot this?

Thank you for your help.

With kind regards,

Hans Vos

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.