[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Trouble with xend-relocation-hosts-allow syntax

Hi all,

  I've had some problem getting the syntax right for
'xend-relocation-hosts-allow' on Xen 3.0/CentOS 5.5.

I've got a two node cluster, and the following in my /etc/hosts file:

================================================       localhost.localdomain localhost
::1             localhost6.localdomain6 localhost6    an-node01.ifn    an-node01.sn    an-node01 an-node01.bcn an-node01.alteeve.com    an-node02.ifn    an-node02.sn    an-node02 an-node02.bcn an-node02.alteeve.com

I've tried various arguments, including just plain using the host names,
but I can't seem to get the magic incantation. I want to enable live
migration on the subnet. I can't seem to get it so that I
can telnet into port 8002 on the other node and on localhost, but could
never get both working at the same time. When I leave it blank,
(xend-relocation-hosts-allow ''), all is good.

I've tried:

(xend-relocation-hosts-allow 'an-node01.bcn an-node02.bcn')
(xend-relocation-hosts-allow '^*\.alteeve\.com$')
(xend-relocation-hosts-allow '^localhost$ ^*\.alteeve\.com$')
(xend-relocation-hosts-allow '^192\.168\.3\.*')

And various other incarnations. Any help would be appreciated!

E-Mail: digimer@xxxxxxxxxxx
AN!Whitepapers: http://alteeve.com
Node Assassin:  http://nodeassassin.org

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.