[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] vlan bridge on gentoo hangs ssh

  • To: Edgar Ricardo Gonzalez Lazaro <ministromayor@xxxxxxxxx>
  • From: Todd Deshane <todd.deshane@xxxxxxx>
  • Date: Wed, 13 Apr 2011 13:36:51 +0000
  • Cc: xen-users mailing list <Xen-users@xxxxxxxxxxxxxxxxxxx>
  • Delivery-date: Wed, 13 Apr 2011 06:38:39 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:sender:in-reply-to:references:from:date :x-google-sender-auth:message-id:subject:to:cc:content-type :content-transfer-encoding; b=gSZTXtBB6NlfznM7MAgynACzQ9vy34ZCz+wygeq0n5TPP2VSeOo/tNKVc8A33nPOwO J2m5IIM9cfxKC/6orrnoo8AOD7mgPy4dvz/uuehq+np2i7pQXX8xbQ5TOhl5Yn8Nl0TZ NB+SwS1PX+go18zANFeZwnDkoeCdWfi4+Bfk8=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>


Maybe this solution will help someone else, so adding back xen-users to the CC.


On Wed, Apr 13, 2011 at 1:25 PM, Edgar Ricardo Gonzalez Lazaro
<ministromayor@xxxxxxxxx> wrote:
> I solved this yesterday, the Dom0 eth0 with mtu 1496 have the bridge with mtu 
> 1500 so the DomU have a nic wirh mtu 1500 something happends between bridge 
> and nic, but I reduced the domU mtu to 1496 and the problem has gone.
> I don't know why but it seems the xen bridge does not handle fragmentation 
> may be a misconfiguration of mine at this level.
> Thanks a lot.
> Edgar Ricardo G. Lázaro
> El 13/04/2011, a las 00:39, Todd Deshane <todd.deshane@xxxxxxx> escribió:
>> On Tue, Apr 12, 2011 at 11:08 PM, Edgar Ricardo Gonzalez Lazaro
>> <ministromayor@xxxxxxxxx> wrote:
>>> I have a Xen Dom0 over gentoo linux, I have configured two vlans over an 
>>> ethernet nic with
>>> 1496 MTU, three bridges have been configured over each, the eth0, vlan1 and 
>>> vlan2, everything seems to be working the DomUs on each bridge can reach 
>>> between them and Dom0 reach all the DomUs but, when I login into one of 
>>> those DomUs with ubuntu server 10.10 and execute the ifconfig command the 
>>> session hangs... nothing but close the terminal is posible. At first I 
>>> guess apparmor could be causing some problem so I uninstalled it but 
>>> nothig, another DomU with SLES11 seems to be having the same behaviour. 
>>> /var/log/messages doesn't gives usefull information nor dmesg.
>>> When I connect to DomU via VNC through Dom0 vnc server nothing wrong 
>>> happends.
>>> Some Ideas?
>> What version of Xen/dom0 kernel are you using on this Gentoo installation?
>> Have you tried disabling checksumming:
>> http://xen.markmail.org/search/?q=%22ethtool+-K%22#query:%22ethtool%20-K%22+page:1+mid:ozu24u7azscw2zwf+state:results
>> You could also take a look at the xend logs and see if the system is
>> also hung when doing xm console during the ssh hang.
>> Thanks,
>> Todd
>> --
>> Todd Deshane
>> http://www.linkedin.com/in/deshantm
>> http://www.xen.org/products/cloudxen.html

Todd Deshane

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.