[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] xenconsole help.

Hello all,

Having installed 2x XCP hosts and added them to a resource pool, configured 
shared storage and generally got ready for operations, I'm currently 
struggling to see anything meaningful of my VM's!!!

I started installing centos form template, but couldn't connect to the 
instance that (successfully) created to complete installation, so, on the 
suggestion of a user here, I've imported the xvp appliance, but can't connect 
to the console to complete the config.

I'm getting :

xenconsole: could not read tty from store: no such file or directory

Now, a cursory google of the above message generally seems to tell me 
xenconsoled is not running, but I've tried running it again, and verified its 
running by :

[root@xen01 ~]# ps ax | grep xenconsoled
 6448 ?        Sl     0:00 /usr/sbin/xenconsoled

But still no joy!

Anybody got any ideas on what I should try next? I've checked what I've found 
to be the usual suspects and just can not make my way past this first vital 
step, so I can actually connect to the VMs I create and can complete 
installations etc.

If it helps, the params of the appliance I'm trying to connect to follows. 

Many thanks!


                    name-label ( RW): xvpappliance                             
              name-description ( RW): Xen VNC Proxy Appliance                  
                  user-version ( RW): 1                                        
                 is-a-template ( RW): false                                    
                 is-a-snapshot ( RO): false                                    
                   snapshot-of ( RO): <not in database>                        
                     snapshots ( RO):                                          
                 snapshot-time ( RO): 19700101T00:00:00Z                       
                 snapshot-info ( RO):                                          
                        parent ( RO): <not in database>                        
                      children ( RO):                                          
             is-control-domain ( RO): false                                    
                   power-state ( RO): running                                  
                 memory-actual ( RO): 268435456                                
                 memory-target ( RO): <expensive field>                        
               memory-overhead ( RO): 4194304                                  
             memory-static-max ( RW): 268435456                                
            memory-dynamic-max ( RW): 268435456                                
            memory-dynamic-min ( RW): 268435456                                
             memory-static-min ( RW): 16777216                                 
              suspend-VDI-uuid ( RO): <not in database>                        
                  VCPUs-params (MRW):                                          
                     VCPUs-max ( RW): 1                                        
              VCPUs-at-startup ( RW): 1                                        
        actions-after-shutdown ( RW): Destroy                                  
          actions-after-reboot ( RW): Restart                                  
           actions-after-crash ( RW): Restart                                  
                 console-uuids (SRO): 1b361d75-5acf-2016-805f-37cca4dab44e     
                      platform (MRW): nx: false; acpi: true; apic: true; pae: 
true; viridian: true
            allowed-operations (SRO): changing_dynamic_range; pool_migrate; 
changing_VCPUs_live; suspend; hard_reboot; hard_shutdown; clean_reboot; 
clean_shutdown; pause; checkpoint; snapshot                                     
            current-operations (SRO):                                           
            blocked-operations (MRW):                                           
           allowed-VBD-devices (SRO): <expensive field>                         
           allowed-VIF-devices (SRO): <expensive field>                         
                possible-hosts ( RO): <expensive field>                         
               HVM-boot-policy ( RW):                                           
               HVM-boot-params (MRW): order:                                    
         HVM-shadow-multiplier ( RW): 1.000                                     
                     PV-kernel ( RW):                                           
                    PV-ramdisk ( RW):                                           
                       PV-args ( RW):                                           
                PV-legacy-args ( RW):                                           
                 PV-bootloader ( RW): pygrub                                    
            PV-bootloader-args ( RW):
           last-boot-CPU-flags ( RO):
              last-boot-record ( RO): <expensive field>
                   resident-on ( RO): a8fa813f-ffd5-4083-8b7f-c5edde895412
                      affinity ( RW): <not in database>
                  other-config (MRW): last_shutdown_time: 20110426T12:57:37Z; 
last_shutdown_action: Restart; last_shutdown_initiator: external; 
last_shutdown_reason: rebooted; disable_pv_vnc: 1; import_task: 
OpaqueRef:bac73e23-0444-63c0-4f61-49eed83da26f; mac_seed: 86439420-4d5f-1605-
b433-4e66d52c439f; linux_template: true; install-repository:; machine-address-size: 36; rhel5: true; install-
methods: cdrom,nfs,http,ftp
                        dom-id ( RO): 3
               recommendations ( RO): <restrictions><restriction field="memory-
static-max" max="34359738368" /><restriction field="vcpus-max" max="8" 
/><restriction property="number-of-vbds" max="7" /><restriction 
property="number-of-vifs" max="7" /></restrictions>
                 xenstore-data (MRW):
                 ha-always-run ( RW): false
           ha-restart-priority ( RW):
                         blobs ( RO):
                    start-time ( RO): 20110426T12:58:06Z
                  install-time ( RO): 19700101T00:00:00Z
                  VCPUs-number ( RO): 1
             VCPUs-utilisation (MRO): <expensive field>
                    os-version (MRO): name: CentOS release 5.5 (Final) 
(xvpappliance 1.9.1-1); uname: 2.6.18-194.32.1.el5xen; distro: centos; major: 
5; minor: 5
            PV-drivers-version (MRO): major: 5; minor: 5; micro: 0; build: 
         PV-drivers-up-to-date ( RO): true
                        memory (MRO):
                         disks (MRO):
                      networks (MRO):
                         other (MRO): platform-feature-multiprocessor-suspend: 
                          live ( RO): true
    guest-metrics-last-updated ( RO): 20110426T12:59:49Z
                   cooperative ( RO): <expensive field>
             protection-policy ( RW): <not in database>
         is-snapshot-from-vmpp ( RO): false
                          tags (SRW):

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.