[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Re: [Xen-users] Guest VM hangs


I haven't tried modifying the guest target memory in xenstore directly before, have you tried using xm mem-set to see if it still hangs? Maybe there is more involved than just setting the target? I know that xm mem-max is also required so chances you may need to set some max value elsewhere in xenstore also..

In terms of writing from the guest you will need to use xenstore-chmod or the C api to modify the permissions first. 

I suggest reading the XenBus article on the wiki:

Kind regards,

On 3 May 2011 11:11, Abhishek Bichhawat <abhishek.bichhawat@xxxxxxxxx> wrote:
When I write something from the dom0 into the /local/domain/<domid>/memory/target using xenstore-write, the respective <domid> guest VM hangs.
What is the reason for this? How to rectify?
And how to set the permissions in the domU. I am not able to do xenstore-write at the shell. It returns an error saying could not write to path.
Kindly help.

Thanks and Regards,
Abhishek Bichhawat
Visiting Scholar
Dept. of Computing
Macquarie University,
Sydney, Australia.

Xen-users mailing list

Kind regards,

Founder | Director
Orion Virtualisation Solutions
 | www.orionvm.com.au | Phone: 1300 56 99 52 | Mobile: 0428 754 846

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.