[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Cannot get sound in a Windows DomU

  • To: Bob Nolty <xen@xxxxxxxxxxxxxxx>
  • From: Liwei <xieliwei@xxxxxxxxx>
  • Date: Tue, 31 May 2011 03:01:03 +0800
  • Cc: xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Tue, 31 May 2011 07:27:02 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:from:date:message-id:subject:to:cc:content-type :content-transfer-encoding; b=CfZFl0VqR9FP+slpd1DNw5Y6sk9Da3T7hB5tIHxGjLZzdk/BQo4E86pv05Z4yRMr3a psy/DbmJm8GaVJ8s2/1abYztozLq/2cWh53NtNeX+D/kvhYXJDE+I52kvKa3C01C9diX /HRupuX2tBHsEAYhvGpW6+JtlNlGf0CELk2kM=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

> Date: Sun, 29 May 2011 23:26:55 -0700
> From: Bob Nolty <xen@xxxxxxxxxxxxxxx>
> Subject: [Xen-users] Cannot get sound in a Windows DomU
> To: xen-users@xxxxxxxxxxxxxxxxxxx
> Message-ID: <201105300626.p4U6QtbJ000843@xxxxxxxxxxxx>
> Hi all --
> I'm a newbie to xen, but have spent about three days reading manuals
> and googling.  I have Fedora 13 as my Dom0, installed Michael Young's
> 2.6.32-xendom0-fc13 kernel package, and created a Vista Business
> 64-bit DomU.  I've been unable to find a Windows driver for AC97 or
> ES1370 audio card that works.  Several I tried would not install; now
> I have an AC'97 driver from Realtek for 64-bit Vista that installs,
> but in Windows Device Manager it says, "This device cannot start".  I
> have looked through my xend.log and qemu-dm-*.log files and don't see
> anything to blame.  (I was getting error messages in the qemu-dm log
> until I loaded OSS emulation into alsa with # modprobe snd-pcm-oss,
> but none now.)  The xend-debug.log has complaints only about the scsi
> bus.
> Can anyone see what's wrong, or let me know what you did to get sound
> working in Vista 64?  Where did you get your driver?  Thanks in advance!
> Bob
> ------------------------------------------------------------------------
> Here are my log files:


I'm looking into this too (since apparently trying to use my
microphone with passthroughed HD audio interface screws things up).
>From what I know, there are no qemu compatible 64-bit AC97 drivers out
there (even the Realtek one which like you said refuses to start).
Likewise for the other audio emulation the xen-bundled qemu provides.

However, in the current qemu release, there is support for Intel HDA
emulation, which 64-bit Windows supports. Unfortunately, the
xen-bundled qemu is heavily patched; so it may take some effort to
transplant the HDA support over, if somebody hasn't tried it yet.

Alternatively, you may use a 32-bit version of Windows, if circumstances allow.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.