[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Re: Xen 4.1.0 compiled from source on Debian Squeeze 6.0

  • To: xen-users@xxxxxxxxxxxxxxxxxxx
  • From: Wouter van Eekelen <me@xxxxxxx>
  • Date: Thu, 2 Jun 2011 10:42:00 +0200
  • Delivery-date: Thu, 02 Jun 2011 02:56:50 -0700
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Seems like part of my e-mail was lost, here is the rest...

At first, when running "xm list", I received this error:
"ImportError: No module named xen.xm"

I saw that /usr/lib/python2.6/site-packages/xen wasn't in sys.path of Python, so I symlinked it to /usr/lib/python2.6/xen - problem solved

Then I received this error:
Error: Unable to connect to xend: No such file or directory. Is xend running?

So I try starting xend:
xencommons should be started first.

So I try starting xencommons:
grep: /proc/xen/capabilities: No such file or directory

A thread on this mailing list suggested I added "none /proc/xen xenfs defaults 0 0" to /etc/fstab
I've done so, rebooted, but the issue persisted.

Another thread suggested I ran 'insmod xen-evtchn' and 'modprobe xen-evtchn', which gave me this error:
FATAL: Error inserting xen_evtchn (/lib/modules/2.6.32-5-xen-amd64/kernel/drivers/xen/xen-evtchn.ko): No such device

And now I'm rather stuck. What am I doing wrong?

On Thu, Jun 2, 2011 at 10:39 AM, Wouter van Eekelen <me@xxxxxxx> wrote:
I installed Debian Squeeze 6.0 on a server and am now trying to install Xen 4.1.0 on it (compiled from source, since the packages don't include Remus support).
Here are the steps I did to install it and get around several errors.

1) Installed Debian Squeeze 6.0 with default options and software RAID 1
2) Installed the dom0 kernel for Debian as shown at http://wiki.xensource.com/xenwiki/XenDom0Kernels
3) Rebooted into the kernel and made sure it was running:
Linux node1 2.6.32-5-xen-amd64 #1 SMP Thu May 19 01:16:47 UTC 2011 x86_64 GNU/Linux

4) Installed the requirements for compiling:
apt-get install zlib1g-dev python-dev libncurses-dev uuid-dev python-dev libncurses-dev libssl-dev xorg-dev uuid-dev build-essential gcc g++ gettext bcc iasl latex2rtf-doc gcc g++ build-essential 

5) Downloaded the 4.1.0 source, untarred it and ran "make world"
6) No errors except a warning about latex for documentation, so I ran "make install"
7) Rebooted again

At first, when running "xm list", I received this error:

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.