[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Error of building dom0 kernel

Hi all,

I follow instructions(http://wiki.xensource.com/xenwiki/XenParavirtOps) to build XEN and dom0 kernel. Building XEN has no problem, but there is an error which I cannot solve to build dom0 kernel.  The brief instructions for building dom0 are get linux-2.6-xen code from git and make ARCH=x86_64 menuconfig, finally generate kernel.deb. (I did every step exactly as the web page says)

First, compiling linux-2.6-xen is ok.
(One  error is drivers/char/apg/intel-agp.c, which is solved by replacing a new version of intel-agp.c)

Then when executing (in order to generate .deb)

sudo fakeroot make-kpkg --initrd --append-to-version=-pv kernel-image kernel-headers

an error occurs:

Errpr:  Kernel: arch/x86/boot/bzImage is ready  (#1)
Building modules, stage 2.
MODPOST 1477 modules
ERROR: "xen_pcpu_index" [drivers/acpi/processor.ko] undefined!
WARNING: modpost: Found 1 section mismatch(es).
To see full details build your kernel with:
make[1]: *** [__modpost] Error 1
make: *** [modules] Error 2

I also tried make ARCH=x86 menuconfig, but it did not work. There are a few threads of the same problem, which did not find the actual answer.  My machine is Ubuntu8 32-bit(2.6.24-19), i5 processor, XEN-4.0.2. I got stuck for several days:(      

I really appreciate your help :_)

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.