[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] XCP 1.1beta - cannot boot from local DVD

  • To: <xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: "Joe Linoff" <jlinoff@xxxxxxxxxx>
  • Date: Wed, 13 Jul 2011 16:36:37 -0700
  • Delivery-date: Wed, 13 Jul 2011 16:37:59 -0700
  • List-id: Xen user discussion <xen-users.lists.xensource.com>
  • Thread-index: AcxBtbVVk3IN6sOvSTqYwLHa8ujvPA==
  • Thread-topic: XCP 1.1beta - cannot boot from local DVD

Hi Folks:

I am trying to install XCP 1.1beta and a single VM on a computer with no
network connections. XCP 1.1 installed just fine but I am having trouble
getting the VM to boot properly from a CentOS 5.5 DVD. 

The first problem was that I could not observe what was happening. Todd
Deshane solved this by showing me how to disable PV VNC and use "xl
console <dom-id>" to connect. That worked perfectly.

The current problem is that during the boot process it tells me that it
does not have a driver for the CD/DVD-ROM but the server boots and
configure properly when I use the CentOS DVD directly instead of trying
to create a VM guest which seems to indicate that it has the proper

How can I debug/fix this? 

My guess is that I made some sort of mistake when configuring the CD-ROM
but I am not experienced enough to figure it out. Note that the
DOM0_CD_NAME="SCSI 1:0:0:0" and the DOM0_CD_DEVICE is "1".

Here is the script that I am using for testing. It simply creates a
guest called test01.  

At lines 8-12 it makes the dom0 CD device not bootable. 

At lines 14-17 it adds the CD-ROM to the VM. I have also attached the
console output. 

I got the steps from this URL:
http://www.xen.org/files/XenCloud/guest.pdf (pg 24): "To install a
supported Linux VM from vendor media using the CLI".

What is really strange to me is that it looks like it is recognizing and
reading the DVD because I had several screens of information that
required answers before I got to this point.

% cat -n make-vm.sh
    1 #!/bin/bash
    3 set -x
    5 # Create the VM
    6 VM_UUID=$(xe vm-install template='CentOS 5 (64-bit)'
    8 # Make the dom0 CD not bootable.
    9 DOM0_CD_UUID=$(xe vbd-list vm-uuid=$VM_UUID userdevice=0
params=uuid --minimal) 
   10 xe vbd-param-set uuid=$DOM0_CD_UUID bootable=false 
   11 DOM0_CD_NAME=$(xe cd-list | grep SCSI | sed -e 's/^.*SCSI/SCSI/') 
   12 DOM0_CD_DEVICE=$( echo "$DOM0_CD_NAME" | awk '{print $2;}' | awk
-F: '{print $1;}')
   14 # Add the CD to domU and make it bootable.
   15 xe vm-cd-add vm=$VM_UUID cd-name="$DOM0_CD_NAME"
   16 DOMU_CD_UUID=$(xe vbd-list vm-uuid=$VM_UUID type=CD params=uuid
   17 xe vbd-param-set uuid=$DOMU_CD_UUID bootable=true
   19 # Disable VNC so that we can use xl console
   20 # URL:
   21 # Citation: Todd Deshane
   22 xe vm-param-set uuid=$VM_UUID other-config:disable_pv_vnc=true 
   24 # Configuration stuff: use the cd-rom, 2 cpus, 2GB RAM, 20GB disk
   25 xe vm-param-set uuid=$VM_UUID
   26 xe vm-param-set uuid=$VM_UUID VCPUs-max=2 VCPUs-at-startup=2
   27 xe vm-memory-limits-set uuid=$VM_UUID static-min=2147483648
4static-max=2147483648 dynamic-min=2147483648 dynamic-max=2147483648
   28 xe vm-param-set uuid=$VM_UUID other-config:disks='<provision><disk
device="0" size="21474836480" sr="" bootable="true" type="system"
   30 # Set the xenbr0 IP address
   31 NETW_UUID=$(xe network-list bridge=xenbr0 --minimal)
   32 xe vif-create vm-uuid=$VM_UUID network-uuid=$NETW_UUID device=0
   34 # Start the VM -- boot off of the CD
   35 xe vm-start uuid=$VM_UUID

% # Get the DOM id
% xe vm-list params=dom-id,name-label,uuid

% # Start the console
% xl console <dom-id>



Attachment: SGKO6J~U.PNG
Description: SGKO6J~U.PNG

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.