[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] XENBUS: Timeout connecting to device

I see no error messages ('device with no driver' means that driver is compiled as module, if mont was successful (last line), all is ok).

I think you stuck at console configuration. Your system boots file but no one response on xen console.

What to do:

put new agetty (or any other getty) in /etc/inittab to listen on xvc0, if this will not works, make it hvc0. ... and pass option console=xvc0 in kernel command line (and try hvc0 if first variant failed).

On 22.08.2011 14:49, Scott Meyers wrote:
I read many postings about such problem, but none solved the problem I have in 

I followed the instructions posted by Pasi Karkkainen at: 

but I did not do the same partitioning. I have 3 partitions: / /boot and /vm on 
on a 2HDs RAID1 server (no LVM). Xen v4.0.1, qemu, libvirt and the kernel was 
built and installed successfully. But, I am unable to create DomU. I ran the 

xm create -f myxennie install=true -c

the system get stuck showing the following error message:

---------- start error message ----------

XENBUS: Device with no driver: device/vbd/51713
XENBUS: Device with no driver: device/vbd/51714
XENBUS: Device with no driver: device/vif/0
XENBUS: Device with no driver: device/console/0
drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
Initalizing network drop monitor service
Freeing unused kernel memory: 524k freed
Write protecting the kernel text: 4172k
Write protecting the kernel read-only data: 1792k
dracut: dracut-004-33.2.el6_0
device-mapper: uevent: version 1.0.3
device-mapper: ioctl: 4.17.0-ioctl (2010-03-05) initialised: dm-devel@xxxxxxxxxx
udev: starting version 147
dracut: Starting plymouth daemon
xlblk_init: register_blkdev major: 202
blkfront: xvda1: barriers enabled
blkfront: xvda2: barriers enabled
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
---------- end error message ----------

I tried different disk methods: tap:aio:/ and phy:/ and file:/ with 
diskimage.img,xvda1,w but keep getting the same error message.

I use "File Based Setup" for Virtual Disks:

mkdir -p /xens/vm001/
dd if=/dev/zero of=/xens/vm001/diskimage.img bs=1024k count=5000
dd if=/dev/zero of=/xens/vm001/swapimage.img bs=1024k count=512

mkfs.ext3 /xens/vm001/diskimage.img
mkswap /xens/vm001/swapimage.img

mount -o loop /xens/vm001/diskimage.img /mnt

Any help is greatly appreciated. Thank you                                      
Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.