[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Help with the migration to XEN-4.1 please


I recently installed XEN on my Gentoo Linux that I use mainly as a
Desktop and I had to switch from xm to xl tool stack.
Since also the gentoo-sources support XEN natively I installed XEN on
my Desktop
distribution too. Well, I started installing XEN as usual, and I was
using it only with the xm tool stack.
Now I read about the migration to the new toolstack at
http://wiki.xensource.com/xenwiki/MigrationGuideToXen4.1%2B but
I have some problem and some question to do.

First of all, let me list my environment:
OS: Gentoo Linux 10.0 kernel: gentoo-sources-3.0.4 arch x86_64
app-emulation/xen-tools-4.1.1-r3 with USE flags: "hvm ioemu"

I also completed the following checklist:
- Configure your host networking using the configuration tools
provided by your distribution.
- Remove any python code from domU configuration files.
- Disable xend startup script (it doesn't exist anymore)
- Use xl command instead of xm (xm doesn't exist anymore)

1) Now the xend initscript has been removed. Well, I had some domain
registered with the command 'xm new vm_name.cfg'.
Actually, performing a "xm list" it was showing them in the list of
the domains after the dom0.
Now that xend has been removed, it is no longer running and 'xl list'
doesn't show any domU in the list. How does it work now?
I tried to put the vm configuration file in /etc/xen/auto but in this
way it starts the vm and not simply it adds to the xen domain store,
letting me decide if starting the vm or not. I was looking for the
analogue command as "xm new config_file.cfg" in xl if exists.

2) If I try to run a gentoo linux guest (for instance) running
'xl vm_config_file.cfg -c' I get the following error:
xenconsole: Could not read tty from store: No such file or directory
But the vm starts even if the networking doesn't work now, of course.
I've already searched and found several results on Google but the
problem is still there. :(

3) the network for the guest OS doesn't work, even the xenbr0 is up
and the vm configuration file
explicitly says it has to use that bridge. Furthermore, due to the
error at point 2, I can't see anything
in the VM.
I also tried to add the following line in the /etc/xen/xl.conf but the
network doesn't work anyway:

4) xl shutdown <domain_number> seems to be not working. I have to
destroy the VM in order to have it powered off.

Can somebody help me to correct these problems please?


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.