[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Re: Serial port pass-through or redirect

After some trials.
I can see console outputs (kernel printk stuff), but still cannot
access it by application.
for example:
/sbin/getty -L -n -l /bin/sh 19200 /dev/ttyS1 vt100
Will be terminated automatically.

On Mon, Oct 17, 2011 at 10:11 AM, Eric Camachat <eric.camachat@xxxxxxxxx> wrote:
> My Xen version is 4.0.1, dom0 is fedora core 12, domU is linux-
> On Sun, Oct 16, 2011 at 10:17 PM, Eric Camachat <eric.camachat@xxxxxxxxx> 
> wrote:
>> Hi,
>> I tried to pass-through ttyS1 (COM2) to domU but never succeeded.
>> My config file:
>> irq=[3]
>> ioports=['2f8-2ff']
>> I can see my domU detect ttyS1 but still cannot drive it. (I can open
>> /dev/ttyS1 but cannot setup its baudrate).
>> If I unbind COM2 from 8250 driver in dom0 then my domU cannot detect
>> any ttyS*, it is weird.
>> I also tried:
>> serial=['pty','/dev/ttyS1']
>> but didn't work either.
>> It is difficult to let my domU to controll ttyS1 (COM2).
>> Thanks,
>> Eric

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.