[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Reporting issues with xen on ubuntu 10.04, 11.04; netbsd 5.1

  • To: xen-users <xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: Dean Anderson <dean@xxxxxxx>
  • Date: Fri, 21 Oct 2011 02:30:55 -0400 (EDT)
  • Delivery-date: Thu, 20 Oct 2011 23:32:23 -0700
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Hey folks,

I've been using xen 3.4.1 on linux (64bit hypervisor and dom0) for a
while now, and recently tried to get my domU system running on ubuntu
11.04 running using Xen 4.1, 4.0 and 3.4 without success. I backed down
to ubuntu 10.04. No luck.  I tried NetBSD 5.1 (Xen 3.3) dom0 and had the
same error:  "Hotplug scripts not working" for networking when starting
domU. I found NetBSD slightly easier to debug, but the solution finally
came when I found this message from 2009, which suggests running
xenbackendd -d.  After that, the domainU, a netbsd 5.0 PAE domain
(previously running under xen 3.4.1 on linux), booted and worked fine.  
Subsequently, xenbackendd doesn't need to be started with -d.

So, it seems like maybe the fix below didn't make it as far as it needed
to go.  I haven't gone back to test the ubuntu combinations but it seems
likely they all have the same solution to the same symptoms. I doubt 
that I will go back to test those unless there is an issue with netbsd 
5.1 as a dom0. Sorry.

Also, I couldn't find any clear statements on whether paravirtualized
systems for 3.4 would still run on 4.0 or 4.1, so I'm not sure what to
expect, but if someone can clear that up I would appreciate it.  I am
quite happy with small footprint bsd systems for domU, but would
appreciate reports on stability as dom0.



Re: "Hotplug scripts not working" when starting domU  
by Sarton O'Brien-2 Feb 19, 2009; 06:29pm :: Rate this Message:    - Use 
ratings to moderate (?)

Reply | Print | View Threaded | Show Only this Message 

Eric Haszlakiewicz wrote: 
> Manuel Bouyer wrote: 
>> On Sun, Feb 15, 2009 at 10:17:07PM -0600, Eric Haszlakiewicz wrote: 
>>> On Sun, Feb 15, 2009 at 11:50:25AM +0100, Jean-Yves Migeon wrote: 
>>>> # /etc/rc.d/xenbackendd stop 
>>>> # xenbackendd -d 
>>> d'oh!  I completely missed the bit about xenbackendd in the 
>>> instructions, and 
>>>  I had only started xend.  With xenbackendd running, I get a bit 
>>> farther, but 
>>>  I'm still seeing some errors about unable to find 
>>> /local/domain/0/... not 
>>>  found.  Then when I tried to kill all the xen proceses because 
>>> things seemed 
>>> to be hanging, I got a panic.  oops. 
>>> Anyway, I seem to have managed to get it working with just the disk 
>>> device, so 
>>>  I'm on figuring how to get the vif line working. 
>> did you create tre bridge it attaches to ? 
> Yeah, I did all that, and got it all working ok.  It was pretty easy 
> once I started all the necessary daemons. 
> So far the only quirk I've run to is that I can't power off the 
> even with a "halt -p" in dom0. 
> However, I'm thinking of starting over, because I didn't realize that 
> there is a newer 3.3 version of Xen.  Is there any reason that I 
> wouldn't want to use the most recent Xen? 
...[show rest of quote]

Av8 Internet   Prepared to pay a premium for better service?
www.av8.net         faster, more reliable, better service
617 256 5494

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.