[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] domU shell prompt freezes after live migration

The suse 2.6.34-xen and 2.6.37-xen works fine in my tests too.

3.1 seems be fine too but have some issues with ballooning (fixes was commited after 3.1 release) and with time (in xen 3).

On 25.10.2011 21:45, David Della Vecchia wrote:
Your welcome. Looks like you fixed the problem by regressing, i tried to fix it by upgrading. I was able to fix my issue of the console freezing after the save and restore but now i am unable to get the networking to work in squeeze domu's after restore.

I was told in the #xen channel to use centos5 as my failsafe test and so far it has earned that title. Throughout all my tests the centos5 domU ALWAYS works with everything. Debian seems to be more finicky unfortunately.

Perhaps i will regress as you have and see if that fixes my networking problem.

Glad to help,

On Tue, Oct 25, 2011 at 1:45 PM, Benjamin Weaver <benjamin.weaver@xxxxxxxxxxxxx> wrote:

We arrived at what may be a related solution. Instead of lucid Ubuntu for the domUs, we dropped back to lenny (2.6.26-2-xen-amd64). The lenny domUs xm store, xm save, and migrate correctly.

None of this explains why on previous installations of our cluster (ocfs2 on SAN + 2 Debian Squeeze dom0s), we did not have problems with lucid vms. But now the lenny s work.

You put us onto the right track with this kernel version problem, and we may well soon be upgrading our dom0s as you suggested.

Thanks very much for your help.

On 25/10/11 15:47, David Della Vecchia wrote:
Yep, 2.6.32-5-xen-amd64 is the one i personally confirm fails at live in this regard.

I run xen4.1.1 in debian wheezy and the kernel i got from kernel.org works flawlessly with the debian squeeze domU's


On Tue, Oct 25, 2011 at 10:37 AM, Benjamin Weaver <benjamin.weaver@xxxxxxxxxxxxx> wrote:
Thanks, David,

This could be very useful. We are running Debian Squeeze for the dom0 (kernel: 2.6.32-5-xen-amd64), but Ubuntu (lucid) for the domUs.


On 25/10/11 15:19, David Della Vecchia wrote:
Are you on debian by chance? I had the exact same issue, it has to do with the kernel you are using for the domU.

Here is the bug report describing it: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=644604

I've had this occur with other kernel's i've built, not just debian provided ones. I was able to build a and a 3.0.1 kernel last night that restored my ability to do xm save and restore without the console lock up.

Hope this helps.


On Tue, Oct 25, 2011 at 9:46 AM, Benjamin Weaver <benjamin.weaver@xxxxxxxxxxxxx> wrote:
I have narrowed down and further defined the problem using xm commands:

1. the problem does not have to do with migration from one node to another per se:

an xm save and subsequent xm restore done from either box, without migration, reproduces the problem. In each case a vm is produced that I can ping and login to, but which produces the frozen prompt.

I have also tried the following:

2. opened permissions on .img files under /ocfs2SAN/domains
to no avail,
therefore not a permissions problem

3. opened up sysctl buffers on both boxes
to no avail
not a sys buffers problem

Might I perhaps have a file system or cluster configuration problem?

Xen-users mailing list

Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.