[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Re : Re : Re : Re : Which kernel may I compile ?

  • To: Emmanuel COURCELLE <emmanuel.courcelle@xxxxxxxxxxxxxxxx>, "xen-users@xxxxxxxxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxxxxxxxx>
  • From: David TECHER <davidtecher@xxxxxxxx>
  • Date: Thu, 5 Jan 2012 15:43:47 +0000 (GMT)
  • Delivery-date: Thu, 05 Jan 2012 15:45:13 +0000
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.fr; h=X-YMail-OSG:Received:X-Mailer:References:Message-ID:Date:From:Reply-To:Subject:To:In-Reply-To:MIME-Version:Content-Type; b=hDQaS51Y1xMrNt3MXoKe12NtGDIrWG7c03McpgLNtsCkrbItsD4v1Q1hAUE3xC+yjioTm+BdSkLgw7x89Hd31ex0ocxY077ppGsEhLoErvjbSOX+x6sovHl+KyoQWAtoeWMIdRGnfaY9mFZnC9eStOjtaxBLvzcLR+IHSU6rVeg=;
  • List-id: Xen user discussion <xen-users.lists.xensource.com>



It should be enough (do not forget 'MB' )

you need to have enough memory to handle the init process

De : Emmanuel COURCELLE <emmanuel.courcelle@xxxxxxxxxxxxxxxx>
À : xen-users@xxxxxxxxxxxxxxxxxxx
Cc : David TECHER <davidtecher@xxxxxxxx>
Envoyé le : Jeudi 5 Janvier 2012 15h58
Objet : Re: [Xen-users] Re : Re : Re : Which kernel may I compile ?

Le 05/01/2012 14:01, David TECHER a écrit :

Do you've got

"Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)" ???????

Yes David, it is this message. However I carefully executed the command:
mkinitramfs -o initrd.img-,

which does the same thing as the command explained by ubuntu.

Well, I think that the problem is that I have put some parameters on the xen command line, as explained here: http://wiki.xen.org/wiki/XenBestPractices
(I did this because I had a crash of dom0 when I tried to give too much memory to my domU, and this indeed solved my problem).

If I use the following grub command (generated by update-grub)
        echo    'Loading Linux ...'
	multiboot       /boot/xen-4.0-amd64.gz placeholder
	module  /boot/vmlinuz- placeholder root=UUID=3bb2e67b-19c8-4916-9977-4ff87983164d ro  quiet
	echo    'Loading initial ramdisk ...'
	module  /boot/initrd.img-
The machine boots fine, BUT if I use the following grub command:
        echo    'Loading Linux ...'
	multiboot       /boot/xen-4.0-amd64.gz placeholder dom0_mem=512
	module  /boot/vmlinuz- placeholder root=UUID=3bb2e67b-19c8-4916-9977-4ff87983164d ro  quiet
	echo    'Loading initial ramdisk ...'
	module  /boot/initrd.img-
it hangs with the message Unable to mount root fs etc.
The funny thing is that everything works perfectly well with the initial Debian kernel (2.6.32-5-xen-amd64).

So, is there a solution, or do I have to avoid any parameter on the xen boot command ?

Emmanuel COURCELLE                emmanuel.courcelle@xxxxxxxxxxxxxxxx
L.I.P.M. (UMR CNRS-INRA 2594/441) tel (33) 5-61-28-54-50
B.P.52627 - 31326 CASTANET TOLOSAN Cedex - FRANCE 

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.