[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] [Xen-devel] VGA passthough still not working

I also have problems using passthrough. I have two graphics cards in my machine and I want to pass one (the secondary) of them to the Windows 7 VM. My system has VT-d, which is enabled, and Windows sees the device and nVidia driver installer works, but that's about it. In the device manager I see two devices with errors. One 'other device' named 'Xen pci device #0' (hardware ID: 'xen\pci') with the message 'The drivers for this device are not installed. (Code 28)' and a 'display adapter' named 'NVIDIA NVS 4200M' (that is correct) with the message 'Windows has stopped this device because it has reported problems. (Code 43)'. Does anyone have any idea what causes these problems and whether this is supposed to work?


On 20-01-12 12:32, Pasi KÃrkkÃinen wrote:
On Fri, Jan 20, 2012 at 05:49:20PM +0100, Sandi Romih wrote:

    I have that enabled in my BIOS, VT-d for the chipset and VT-x for the CPU.

Ok. And Xen enables IOMMU? Did you verify from Xen's dmesg ?


    Have you managed to pass your gpu through to the domU?

No, I haven't tried that yet. I've been planning to, but I haven't had time for 
it yet.

There are many people who are using Xen VGA passthru with Intel, AMD/ATI and 
Nvidia graphics cards.
Currently it needs a lot of understanding and some custom patching, but you can 
make it work.

There are even businesses using Xen VGA passthru in production :)

-- Pasi


    On Jan 20, 2012 4:47 PM, "Pasi KÃrkkÃinen"<[1]pasik@xxxxxx>  wrote:

      On Fri, Jan 20, 2012 at 02:05:43PM +0100, Sandi Romih wrote:
      >     Hello,
      >     I have spent a lot of time trying to get gfx passthru working on my
      >     without success.
      >     I looked onto my hardware capabilities again to make sure that it
      >     support VT-d and I am not too sure that it does fully.
      >     My hardware is as follows:
      >     - Supermicro X8DTH-6F motherboard (5520 chipset which supports
      >     - single Xeon X5650 CPU (which is listed as supporting VT-x, no
      mention of
      >     VT-d at [1][2]ark.intel.com)
      >     Now, according to the [2]VTdHowTo, the motherboard BIOS, chipset
      AND CPU
      >     need to support VT-d.
      >     What confuses me is, why is the 55x0 chipset listed there if none
      of the
      >     CPU's supported, that I know of, dont have the VT-d feature option,
      >     VT-x.

      I've been using VT-d with Xen with Intel 5500 series chipset, and Xeon
      5600 series CPU.
      VT-d needs to be enabled in the BIOS.

      -- Pasi


    Visible links
    1. mailto:pasik@xxxxxx
    2. http://ark.intel.com/

Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.