[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Xen-users Digest, Vol 84, Issue 19

Hi Everyone!

I will answer my own question, because I have solved the problem.

It turned out to be because of "VT-d" option enabled in BIOS. Probably the stock debian kernel and other distros I have mentioned have passthrough options enabled, thus
the RAID card was given to XEN for usage somehow. With disabling the option, everything started to work flawlessly.

There is probably a method to disable the passthrough of the RAID-card only and you don't  need to disable VT-d globaly, but for me this is a solution for now. There are also servers that do not have VT-d option in
their BIOS, so maybe there another solution will be needed (kernel recompile without passthrough options).

BTW I have also tried acpi=off which made me able to boot in some situations, but xend did not want to start, so I took the option out. I have read somewhere that this is also a solution sometimes to similar problems, but not for mine I guess. VT-d disable worked like a charm!


Hi Everyone!

I have got a problem I have been dealing with for many weeks now.

I have a Supermicro server with an Intel SRCSASPH16I RAID-card (which is
also known as LSI Megaraid SAS 84016E, just with Intel BIOS installed).

Now my basic problem is:

I can install all kind of linux distros without a problem, but when I
install the xen stuff, the system does not boot up, it has problems with
the disk. The distro I know it works flawlessly is with CentOS 5.x with
2.6.18 kernel.
The distros it had problem with: OpenSUSE 11.4 (2.6.37), OpenSUSE 12.1
(3.x.x), Debian Squeeze (2.6.32), Debian Wheezy (3.x.x).
The weird thing is that everything is fine until I boot up the xen stuff,
so without the xen stuff, evertyhing boots up OK. In the 3.x.x kernel
distros this is really frustrating, because there the kernel includes the
xen code, so only xen.gz can cause such problems. It can't be a driver
problem, altough I wanted to try to install the new drivers from Intel and
also from LSI, but it seems that 3.x.x kernel is not supported.

It has got this card with lspci:
03:0e.0 RAID bus controller [0104]: LSI Logic / Symbios Logic MegaRAID SAS
05:00.0 SCSI storage controller [0100]: LSI Logic / Symbios Logic MegaRAID
SAS 8208ELP/8208ELP [1000:0059] (rev 08)

Here are some screenshots of my experiments. I have tried with ext2 all,
ext3 all, btrfs all, ext4 all, lvm or without lvm etcetc...


Please give me some ideas about what I can/should do!


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.