[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] xenconsole: Could not read tty from store: No such file or directory

Hallo Su Zhang,
you are right. The file with the #XENCONSOLED_TRACE= option is    /etc/sysconfig/xencommons  on xen 4.1.2.
Yes I agree my "resolved" problem seams to be different than yours. Because your xenconsoled ist running and you does not have enabled logging by #XENCONSOLED_TRACE= option.
The directory /var/log/xen/console  is only needed if xenconsoled logging is activated and the logging destination is not redirected by --log-dir (-r) switch to else where.
I am sorry that I could not help.
-----Ursprüngliche Nachricht-----
Von: xen-users-bounces@xxxxxxxxxxxxx [mailto:xen-users-bounces@xxxxxxxxxxxxx]Im Auftrag von Su Zhang
Gesendet: Dienstag, 20. März 2012 17:03
An: Andreas Greve
Cc: xen-users@xxxxxxxxxxxxx; Ian Campbell
Betreff: Re: [Xen-users] xenconsole: Could not read tty from store: No such file or directory

On Tue, Mar 20, 2012 at 2:33 AM, Andreas Greve <andreas.greve@xxxxxxxxxx> wrote:
Hallo Su Zhang,
sorry for the short answer yesterday it was written on train on my handy.
/var/log/xen/console must be a directory.
There is no any file or directory called /etc/default/xen*.
Sorry that was specific to my debian system.  The correct name is

There is no file at /etc/sysconfig/xend, instead, there are files called /etc/sysconfig/xencommons and /etc/sysconfig/xendomains  
If in this file the  option
is aktivated and set to all (in my case) and if the directory /var/log/xen/console  does not exist
the daemon xenconsoled dies directly after start on boot because xenconsed want to write to /var/log/xen/console/hypervisor.log.
but the directory does not exist.
There is a line "#XENCONSOLED_TRACE=[none|guest|hv|all]" within /etc/sysconfig/xencommons. Currently, this line ("#XENCONSOLED_TRACE=[none|guest|hv|all]") is commented out, so it seems that it is not activated right now?
again, there is no file or directory at /var/log/xen/console in my file system.
Bevor you try to start a DomU look if xenconsoled is running (ps augx | grep xenconsoled). If xenconsoled is not running perhaps you have the same problem.

Actually, I the output of the command line does indicate that the xenconsoled is running:

[root@XenTester su]# ps augx | grep xenconsoled
root      3826  0.0  0.0  90480   348 ?        SLl  10:10   0:00 xenconsoled --pid-file=/var/run/xenconsoled.pid
root      5119  0.0  0.0 103284   800 pts/2    S+   10:53   0:00 grep xenconsoled
[root@XenTester su]#

So it seems that your issue is not exactly same as mine because the XENCONSOLED TRACE is inactivated under my default settings, do you think so?
my way arround the problem was (as root):
    mkdir /var/log/xen/console
starting daemon by hand
making sure the the xenconsoled is running
    ps augx | grep xenconsoled
and than trying to start a domU (pv).
    xm create <domU>
After that all works fine for me including for a system reboot too.
I inspected the "make install" of  (4.1.2) and  only found the creation of  /var/log/xen directory but nothing for the creation of
/var/log/xen/console. But the source from xenconsoled depends on that directory.
So I think that it is a bug in the "make install"  
-----Ursprüngliche Nachricht-----
Von: Su Zhang [mailto:westlifezs@xxxxxxxxx]
Gesendet: Dienstag, 20. März 2012 02:46
An: Andreas Greve
Cc: Ian Campbell; xen-users@xxxxxxxxxxxxx
Betreff: Re: [Xen-users] xenconsole: Could not read tty from store: No such file or directory

On Mon, Mar 19, 2012 at 1:56 PM, Andreas Greve <andreas.greve@xxxxxxxxxx> wrote:
if it is a pv then look if the directory /var/log/xen/console exists. If some logging options in /etc/default/xen* are enabled xenconsoled does not start on boot. Because it could not write to /var/log/xen/console/hypervisor.log. The make install does not create the missing directory (4.1.2) .
I run in this problem today.
I hope the above helps you.


  Hi Andreas,

   Thanks for your reply. Interestingly, the file /var/log/xen/console doesn't exist on my machine. There is no any file or directory called /etc/default/xen*. So how did you address the similar problem? Could you please be a bit specific? Do I need to generate these files manually? Or  How can I generate these files automatically? Is this issue caused by these missing files?


Ian Campbell <Ian.Campbell@xxxxxxxxxx> schrieb:
On Sat, 2012-03-17 at 16:30 +0000, Su Zhang wrote:
> On Sat, Mar 17, 2012 at 3:24 AM, Ian Campbell
> <Ian.Campbell@xxxxxxxxxx> wrote:
> On Fri, 2012-03-16 at 23:45 +0000, Su Zhang wrote:
> > Hello Community,
> >
> > I encountered an error while running "xm console domU". Here
> is the
> > running script:
> >
> > # xm console domU
> > xenconsole: Could not read tty from store: No such file or
> directory
> >
> > I googled and found out that this issue is mostly result
> from
> > forgetting starting xenconsole service.
> > However, after I started xenconsole, the issue is still
&gt! ; there. Please

> > see:
> You might need to restart your guests and/or toolstack after
> starting
> xenconsole.
> This should all have been taken care of by the initscripts
> shipped with
> xen -- are you not using them for some reason?
> Ian,
> Do initscripts here refer to the xen-related scripts
> under /etc/init.d/ ?
> Like xencomms?

xencommons, yes.

> [...]

> [root@XenTester su]# virt-install -l
> http://mirror.centos.org/centos/5/os/i386/ -p -n f13 -r 768 --vcpus=1
> --disk=/srv/xen/mailserver.img --graphics vnc,listen=,port=5901
> --noautoconsole

I'm not at all familia! r with virt-install or Fedora but given this

domain is to be called "f13" I would have expected a Fedora mirror to be
listed rather than the CentOS 5 mirror. Is this normal?

Do you know if this command will create a PV or an HVM guest?

If this is an HVM domain then it is possible that it simply doesn't have
a text console which you can connect to with xl console. The "Could not
read tty from store" message is often indicative of this.

It appears you have configured VNC for this domain, have you tried
connecting a vncviewer to port 5901 on the host? e.g. vncviewer
localhost:1 or localhost::5091 (check the vncviewer manpage, I'm not
sure of the syntax). Perhaps virt-* includes a command to do this for
you automatically?

If you want a text console from an HVM guest then you can do the
virt-install equivalent of adding
series = 'pty'
to your guest configuration. I'm afraid I don't know h! ow to actually do

that with virt-install though.

If this is a PV guest then I have no idea what might be wrong.


Su Zhang
Ph.D Candidate
Computing and Information Sciences
Kansas State University

Su Zhang
Ph.D Candidate
Computing and Information Sciences
Kansas State University
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.