[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Call trace when attempting to start oprofile

Hello Xen community, 

I am trying to run oprofile in my dom0, but get a crash (displayed as a call trace in dmesg) as soon as I run opcontrol --start.
I assume this is a Xen problem because the first line reads: 

WARNING: at /build/buildd/linux-3.0.0/arch/x86/xen/enlighten.c:732 xen_apic_write+0x1a/0x20()

The corresponding full dmesg output is available at the following pastebin: http://paste.ubuntu.com/895198/

Xen version is 4.1.1, booting a x86_64 3.0.0-17 dom0 kernel. Oprofile is version 0.9.6. Those are the latest packages available for ubuntu oneiric for both kernel and Xen. I chose to install from ubuntu packages for convenience (not having to build Xen from scratch, etc..)
CPU is an AMD Opteron Processor 6168.

Right before I run opcontrol --start, I do: opcontrol --setup --vmlinux=/usr/lib/debug/boot/vmlinux-vmlinux-3.0.0-17-server
I tried with --no-vmlinux, same result.

I also tried booting the aforementioned kernel directly as well, with no hypervisor involved at all, and did not get any call traces or crashes (obviously, since Xen is no longer involved, but I wanted to make sure there isn't something else going on).

Googling didn't help much, I just found references to other pastebins with similar traces, but could not find any post referencing those pastes. I am not sure if this issue is known or has even been fixed in development versions.

I am not sure about what is going on and how to proceed. I can only think of trying another Xen version, maybe a development version, but I'm not even sure that will work. Maybe there is a workaround? I would appreciate any suggestions :-)

Thank you in advance,

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.