[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] ATI Catalyst BSOD

Hello Casey,

That's excellent news!  I'm glad I was able to help someone with that tip :)

Full VGA Passthrough---registering the VGA BIOS with the HVM QEMU
BIOS---is some awesome stuff.  I just wish my foray into Xen had ever
gotten it to work! It was that failure and other problems (like trying
to figure out how to edit boot menus with GRUB2 when I just want to
edit the config file! grr...) that led me to ultimately run ESXi for
the pet project I took on.

I would much, much rather have the control and functionality that Xen
offers... if you can put up a good step-by-step guide running on top
of Debian (possibly Ubuntu?) I'd love to take a stab at duplicating
your results on my quad-head system.  Some small problems that I'm
running into with VMware didn't exist on Xen, and I'd really love to
get it up and running, in all its glory, on top of Xen, and then make
a fun tutorial of my own. :)

Please do keep us posted on your progress!  Great to hear someone's
having fun, and a bit of good luck too!

Andrew Bobulsky

P.S. By the way, if you right click the desktop of your Dom-U and
click "Screen Resolution," you should be able to see the monitor's
model there.  I can't say I've ever heard of an LCD that performs
under- or overscan, given the pixel-perfect nature of

On Wed, Mar 28, 2012 at 1:14 AM, Casey DeLorme <cdelorme@xxxxxxxxx> wrote:
> Status Update:
> Following Andrew's suggestion VGA Passthrough was a success.  I have been
> testing all day and also sorta figured out the one bug I mentioned.
> Without CCC I can't control special functionality such as scaling or
> over/under scan.  When connected to my ASUS 23.5" HD Monitor this was a
> problem, I tried both DVI to HDMI and HDMI to HDMI.  However, when I
> connected the HDMI to my HDTV, the screen on my HDTV is filled, the monitor
> remains the same.  I believe this means my HD Monitor has a higher native
> resolution than 1920x1080, however I don't know the model off hand.
> In any event, CCC won't install, and I test advanced configuration changes,
> that is the only downside thus far.
> I also passed the onboard audio and tested it successfully, as well as
> onboard USB 2.0 and USB 3.0 chipsets (I have two of each leaving me plenty
> for the console/Dom0 keyboard).
> USB 3.0 is finicky; it worked fine for my Logitech G11 & G110 keyboards,
> Microsoft (wired) laser mouse, and the XBox 360 Wireless Adapter.
> However, my ASUS BT211 BlueTooth Dongle/Adapter is recognized but fails to
> install drivers, similarly my Logitech C910 HD WebCam drivers install but I
> only get audio no video, and similar results with a Happauge HD PVR.
>  However, these three devices work 100% when connected to USB 2.0 ports
> instead.
> Many guides for VGA Passthrough use the XM Toolstack, this is working for me
> with the XL toolstack, not sure if this is important to anyone.
> The greatest issue I am encountering thus far is when I shut down the HVM,
> xl list still shows a zombie record with some memory & vcpu's attached, the
> name is (null).  I can't restart the HVM after shutting it down unless I
> reboot the host.
> I actually did not have this issue when I compiled Xen 4.2 unstable from
> source previously, so I plan to try that again soon as I also want to test
> EFI Bootloader compatibility.
> I am documenting my steps, so I hope to put together a nice detailed &
> complete walkthrough on the Xen wiki once I get Xen 4.2 Unstable working.
> ~Casey
> On Tue, Mar 27, 2012 at 2:59 PM, Andrew Bobulsky <rulerof@xxxxxxxxx> wrote:
>> Hello Casey,
>> I experienced the same problem on VMware.
>> The problem for me was *somehow* related to Catalyst Control Center.
>> I wish I knew why.  I can't think of a single good reason that CCC
>> would cause a crash, but it does.
>> Try omitting CCC from the install process, and it may work for you!
>> Cheers,
>> Andrew Bobulsky
>> On Tue, Mar 27, 2012 at 2:53 PM, Casey DeLorme <cdelorme@xxxxxxxxx> wrote:
>> > Still trying to get Windows 7 x64 and VGA Passthrough functional.
>> >
>> > After plenty of testing with an nVidia GTX 460, including both patched
>> > and
>> > non-patched versions, the furthest I came was a basic install which
>> > recognized the card by it's name, allowed drivers to install, but won't
>> > activate with a Code 43 in Device Manager.
>> >
>> > At the recommendation of many, I purchased an AMD ATI Radeon HD 6870.
>> >
>> > My Dom0 is Debian, I have tried both Squeeze and Wheezy, a compiled
>> > 4.1.2
>> > and 4.2, as well as a pre-packaged (aptitude) 4.1.2 and 4.0 (on
>> > squeeze).
>> >
>> > In all cases, Windows 7 x64 installed, I could pass the card to the HVM,
>> > and
>> > it would install default Windows drivers that would give then pass
>> > graphics
>> > to the physically connected monitor (by means of DVI out).
>> >
>> > This also means my VNC display goes blank after booting (which is fine
>> > as an
>> > end result).
>> >
>> > However, upon attempting to install the ATY Catalyst Drivers, I get a
>> > BSOD
>> > which claims atikmpag.sys file is the cause, but I have no further
>> > information.
>> >
>> > I have tried from version 9.12 up to the latest 12.2, the results are
>> > the
>> > same.
>> >
>> >
>> > Has anyone else encountered this, if so how did you resolve it?
>> >
>> > If you have not encountered this, can you send me the list of steps you
>> > took
>> > to setup and install your system?
>> >
>> > I can't seem to find a guide that starts at "Setting up Dom0" to
>> > "Installing
>> > VGA Drivers in HVM".
>> >
>> >
>> > I would greatly appreciate some guidance.
>> >
>> > Thanks,
>> >
>> > ~Casey DeLorme
>> >
>> >
>> > Additionally, I have not been successful with the module pciback, I had
>> > to
>> > custom compile the linux kernel for it to function right.  I was told
>> > Debian
>> > Squeeze had this "built-in", but the net install version 6.04 kernel
>> > flag is
>> > set to "m" not "y".
>> >
>> > In any event, if anyone has additional tips on pciback as a module, and
>> > specific controls (such as how to undo a hidden device) that would be
>> > super
>> > helpful.  So far everytime I hide a device, even if I remove the grub
>> > command the device is no longer accessible from Dom0, this has created
>> > problems as I can't seem to re-attach devices to Dom0.
>> >
>> > _______________________________________________
>> > Xen-users mailing list
>> > Xen-users@xxxxxxxxxxxxx
>> > http://lists.xen.org/xen-users
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxx
> http://lists.xen.org/xen-users

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.