[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Unable to boot installation ISO

Ok, to make a follow up on my original email, I tried linux rescue CD (systemrecue cd) and it booted. I saw that it dosent (or dosent appear to) support native Xen frontend driver so sees the cdrom in HVM.
the gentoo seems to support native xen drivers (when booting, I can see the disk with xvda : xvda1, xvda2, etc)
maybe the ISO dosent support a native xen cdrom driver (if there is one) ? 
-------- Original Message --------
Subject: Re: [Xen-users] Unable to boot installation ISO
From: "John F. Acree" <john@xxxxxxxxxxxx>
Date: Wed, April 04, 2012 11:40 am
To: xen-users@xxxxxxxxxxxxx


I have had a similar problem, and as yet have not had a chance to take
the screenshot as was requested earlier(maybe this weekend I can get to it.)

My solution, until it can be figured out what needs to be changed so the
gentoo minimal cd will boot, is that I used an ubuntu cd.

I am writing up instructions on this approach, but might be several days
or weeks before I release it(my first attempt at technical documentation.)

Basic steps:
Select other install media.
Load the ubuntu iso or cd.
Format the target drive.
Copy down the gentoo stage3 and portage archives to the target drive.
Extract packages, per install instructions.
Chroot as normal and continue with the install instructions.

Hope this helps. But I am not using a gentoo dom0, using xcp 1.5, so
there are differences.


> Hi,
> I build Xen 4.1.1 on a Gentoo base dom0. Everything is working great. I
> tried one of Joseph Glanville's PV-HVM image (debian6) and its working
> as it should.
> Now l'im trying to build a Gentoo based domU with then same specs as
> Joseph's PV-HVM.
> I used a copy of the .cfg and adapted to my needs to make the gentoo work.
> when booting the minimal install image using the iso, it starts loading
> the CD and then when trying to mount the cd-rom it dosent see it .
> here is a copy of the .cfg i used:
> kernel = 'hvmloader'
> builder = 'hvm'
> memory = 4096
> vcpus = 4
> name = "vm-vps3"
> vif = [ 'bridge=virbr0' ]
> disk = ['phy:/dev/vgPool1/VM-VPS3,hda,w',
> 'file:/mnt/iso-images/gentoo/amd64/install-amd64-minimal-20120223.iso,hdc:cdrom']
> acpi = 1
> boot = 'd'
> sdl = 0
> serial = 'pty'
> xen_platform_pci = 1
> vnc = 1
> vncpasswd = 'password'
> vnclisten = 'localhost'
> vncdisplay = '343'
> I tried with xen_platform_pci set to 0 but the just hangs to boot
> procedure when loading the sata_piix module.
> any ideas on this ?
> Thanks,
> J-F
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxx
> http://lists.xen.org/xen-users

John F. Acree
ideacode, Inc.
www.ideacode.com / (main) +1 919 341 5170 / (fax) +1 919 521 4100


Xen-users mailing list
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.